1

The issue I have is that, when trying to connect my bluetooth to my laptop (under Xubuntu 16.04), the speakers pair well, but once they are paired, I go on to click on "Audio sink", and I immediately get this error message :

Connection Failed: blueman.bluez.errors.DBusFailedError: Protocol not available.

I have tried every solution I found online but none of them work, thank you if have a solution to this problem :)

0

I followed this, and it worked even though it wouldn't work multiple times. I think it is because I didn't properly close every program involved (blueman/pulseaudio) before executing the command

  • See Step 6 of my Answer below in Provide Information on Bluetooth Applications, and I think I can get you a fix. – eyoung100 Jun 30 '16 at 22:06
  • What I meant was I think I found a permanent solution, thanks a lot for your help though – Lilian A Jun 30 '16 at 23:17
0

Let's start here, as these comments are getting out of control. I'll provide what I need, and you can either edit my Answer, or edit your question. I realize PulseAudio and bluetooth aren't necessarily related, but I want to make sure that all the other pieces are properly fresh.

Starting With A Clean Slate

Let's clean out PulseAudio's Configuration and Installation so we all start on a clean slate:

  1. If you are using Ubuntu 12.04 LTS (Precise Pangolin) or later, try this first: killall pulseaudio; rm -r ~/.config/pulse/* ; rm -r ~/.pulse*
  2. Issue: pulseaudio -k
  3. Remove your particular desktop, in case you aren't using the default desktop. Sorry, but I need a Baseline. Stop after the clean command. Before rebooting, let's remove PulseAudio. See Step 4.
  4. To remove and reinstall PulseAudio issue: sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status
  5. Disconnect all Bluetooth devices.
  6. Reboot.
  7. Reinstall Unity, and Ubuntu Desktop. See the last of the post I linked in Step 3. At this point, you should have audio in hardware speakers.
  8. Enable Unlimited Scrolling in your Terminal: Start a new terminal, and click Edit > Profiles > "Default" profile > Scrolling. Choose "Unlimited" as scrolling option. Click Close and Close again.
  9. Verify or add your user to the following groups using usermod -aG: pulse, audio, pulse-access, pulse-rt, video: cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami

Provide Information About ALSA and PulseAudio

  1. Download the ALSA script: wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh.
  2. Provide information here about ALSA: bash alsa-info.sh --stdout.
  3. Provide the following information about your devices: cat /proc/asound/{version,cards,devices,hwdep,pcm,seq/clients}; sudo rm /etc/asound.conf; sudo rm -r ~/.pulse ~/.asound* ;sudo rm ~/.pulse-cookie; sudo apt-get update; sudo apt-get install aptitude; sudo aptitude install paman gnome-alsamixer libasound2-plugins padevchooser libsdl1.2debian-pulseaudio; sudo lshw -short;ls -lart /dev/snd; find /lib/modules/uname -r| grep snd ;cat /dev/sndstat; lspci -nn; lsusb; sudo which alsactl; sudo fuser -v /dev/dsp /dev/snd/* ; dpkg -S bin/slmodemd; dmesg | egrep 'EMU|probe|emu|ALSA|alsa|ac97|udi|snd|ound|irmware'; sudo /etc/init.d/sl-modem-daemon status; sudo grep model /etc/modprobe.d/* ; sudo dmidecode|egrep 'anufact|roduct|erial|elease'; lsmod | egrep 'snd|usb|midi|udio'; pacmd list-sinks; aplay -l; sudo alsa force-reload; ubuntu-support-status ; sudo lshw -C sound
  4. Provide a PulseAudio startup log: sudo gedit /etc/pulse/client.conf. Add extra-arguments = -vvvv --log-target=newfile:/tmp/pulseverbose.log --log-time=1 to the End of the file. Reboot && Post the content of the log here.

Provide Information on Bluetooth Applications

  1. apt-cache policy pulseaudio.
  2. apt-cache policy bluez.
  3. apt-cache policy blueman.
  4. apt-cache policy pulseaudio-module-bluetooth.
  5. Verify your Ubuntu release: lsb_release -rd
  6. Post the contents of /etc/pulse/default.pa.

References

UbuntuWiki - SoundTroubleshootingProcedure
PulseAudio Bug 1274613 - LaunchPad
UbuntuWiki - PulseAudio Logging
Ubuntu Forums - (Solved) module-bluetooth-discover not loading on startup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.