0

I have ubuntu 14.04 and nvidia 660m. I have read several similar questions but non of them solved my problem. My problem is that either CUDA does not detect my gpu or I cannot login to ubuntu after reboot. Here's what I've done:

I used the xorg-edgers ppa to install the drivers via apt.

sudo apt-get install nvidia-352

Then I downloaded the same driver version from nvidia website and installed it because I read that I need the nividia's .run file to install cuda. Although it showed me that the pre-installation script failed, I forced it to install. And everything went fine and CUDA detected my gpu. (Without installing nvidia's .run file, CUDA fails to detect my gpu).

However, after rebooting, I could not pass the login screen any more. To resolve it, I followed the instructions in this question (uninstalling the .run file and uninstalling all nvidia drivers and reinstalling via ppa again) and I was able to login. However, now CUDA does not detect my gpu anymore. I tried reinstalling the .run file and the same happens. I can use CUDA just before I reboot and after reboot, I can't login.

How can I make CUDA work with NVIDIA?

Thanks

  • Please use CUDA from repository and then you can install the existing driver in 14.04 or latest via Graphics PPA. Make sure nvidia-modprobe is installed to make CUDA detect your GPU. Install nvidia-modprobe and reboot. – Arup Roy Chowdhury Jul 4 '16 at 15:49
  • It didn't work. It doesn't detect my driver. CUDA only detects the driver when I install the driver from the .run file. However, if I do that, I get stuck at login screen. – CentAu Jul 5 '16 at 16:56
  • modprobe: ERROR: ../libkmod/libkmod-module.c:809 kmod_module_insert_module() could not find module by name='nvidia' modprobe: ERROR: could not insert 'nvidia': Function not implemented – CentAu Jul 5 '16 at 16:57
  • I got it to work finally. Found the answer from here: codeyarns.com/2015/09/25/how-to-install-cuda-7-5-on-ubuntu – CentAu Jul 5 '16 at 19:21
0

No answer about login issue. But to install cuda 7.5 you could use :

https://github.com/NVIDIA/DIGITS/blob/digits-3.0/docs/UbuntuInstall.md#repository-access 
  • This didn't solve my problem. – CentAu Jul 5 '16 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.