3

I am not a sysadmin, so I am almost ignorant on this. I have a laptop connected via wlan interface and I want to use lxd containers and the network inside the containers. here https://insights.ubuntu.com/2016/04/07/lxd-networking-lxdbr0-explained/ are mentioned a number of way of doing it. By mistake I did some of those (and not just one), it was because the first does not work for me. Now I have:

# lxc profile show default
name: default
config: {}
description: Default LXD profile
devices:
  eth0:
    name: eth0
    nictype: macvlan
    parent: eth0
    type: nic

I supposed that I should say this

# lxc profile device set default eth0 parent wlan0

then I have

name: default
config: {}
description: Default LXD profile
devices:
  eth0:
    name: eth0
    nictype: macvlan
    parent: wlan0
    type: nic

into the container I have:

# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
30: eth0@if3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1
    link/ether 00:16:3e:a8:bc:a6 brd ff:ff:ff:ff:ff:ff link-netnsid 0

No network connection. Also, do I need to disable bridge on lxd (with dpkg-reconfigure)? I have old /etc/default/lxc-net file and lxd-bridge that looks very similar, should I remove the lxc-net?

Thank you

EDIT 1

I switched to bridged network, with this configuration:

devices:
  eth0:
    nictype: bridged
    parent: lxdbr0
    type: nic

the problem was network port 53 in use (log message reports "address in use"). It was bind listening on 0.0.0.0:53 that is the default. dnsmasq would to run and can not

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.