0

First of all, I'm aware of this question and this one, and I don't believe this is a duplicate. I've encountered that problem (and solved it using those answers) on two different laptops. This problem, however, I believe is different. I suspect it might have something to do with the fact that Xubuntu is running under chroot.

Also, I realize this may not be solvable at all. I know that VB depends on some sort of virtualization setting in the BIOS. My device doesn't even have a BIOS.

Alright, this is Xubuntu Xenial (x86-64) running under chroot on an Android device. (Details here). It's not a virtual machine. Android and Xubuntu both share the same Linux kernel, and in Android's system monitor, I can see Xubuntu processes as separate tasks. This device has an x86‑64 2.3 Ghz quad core CPU and 4 GB RAM.

By the way, due to the Android thing I'm running an old kernel. uname -a gives

Linux localhost 3.10.20-x86_64_moor-gc55829a #1 SMP PREEMPT Wed May 4 01:08:33 CST 2016 x86_64 x86_64 x86_64 GNU/Linux

Alright, so I run VB by typing virtualbox into the Terminal.

The program starts, but I also get this warning:

android@localhost:~$ virtualbox
WARNING: The character device /dev/vboxdrv does not exist.
     Please install the virtualbox-dkms package and the appropriate
     headers, most likely linux-headers-gc55829a.

     You will not be able to start VMs until this problem is fixed.
Xlib:  extension "XInputExtension" missing on display ":0.0".

In spite of this warning, however, the GUI still appears. However, when I try to run any VM, I get the following message:

Failed to open a session for the virtual machine [name].

Clicking a button that says Details gives the following message:

The virtual machine '[name]' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: MachineWrap Interface: IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}

A separate box says:

Kernel driver not installed (rc = -1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please install virtualbox-dkms package and load the kernel module by executing

'modprobe vboxdrv'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

Things I have tried:

  • This answer. All the information given in this question is after having done that.
  • This:

android@localhost:~$ sudo modprobe vboxdrv

modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/3.10.20-x86_64_moor-gc55829a/modules.dep.bin'

modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/3.10.20-x86_64_moor-gc55829a

android@localhost:~$

  • Have you done this: sudo /etc/init.d/vboxdrv setup? – ubashu Jun 29 '16 at 20:29
  • And could you post the output of: sudo apt-get install linux-headers-generic build-essential dkms sudo apt-get remove --purge virtualbox-dkms sudo apt-get install virtualbox-dkms – ubashu Jun 29 '16 at 20:30
  • Also, what is the kernel version that both devices share? – eyoung100 Jun 29 '16 at 20:38
  • @collDue96 The output of that was sudo: /etc/init.d/vboxdrv: command not found – Revetahw Jun 29 '16 at 21:00
  • @collDue96 And as for those other commands, I've ran all of them, and they went flawlessly. No errors. – Revetahw Jun 29 '16 at 21:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.