3

I followed all of the indicated steps to install Apache Mesos, but after running the $ ../configure command, i get an error saying that 'libz' is a requirement. I've tried to google 'libz' but i'm not getting a clear solution. Can anyone point me in the right direction on this?

  • As far as I can tell, Apache Mesos hasn't published releases for 16.04 yet, so I wouldn't expect the one that you downloaded to work. – edwinksl Jun 29 '16 at 17:44
  • @edwinksl i see, that could definitely be a factor. So roll back to 14.04? – PyNoob Jun 29 '16 at 17:45
  • 3
    Hmm, maybe there may be ways to do this. Can you try sudo apt install zlib1g-dev and compile Apache Mesos again? – edwinksl Jun 29 '16 at 17:58
  • @edwinksl thank you, i'll give that a try tonight. Can't right now. I'll let you know if it works. – PyNoob Jun 29 '16 at 18:19
  • @edwinksl hey buddy, your solution worked. Please post as an answer so i can accept and upvote – PyNoob Jun 30 '16 at 1:28
5

This solution is courtesy of edwinksl

sudo apt install zlib1g-dev

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.