23

For some reasons the animations really slow up my Ubuntu virtual machine. How can I disable all the frilly animations?

  • Super Key Dashboard fade-in/fade-out
  • Alt+Tab fade-in/fade-out
  • Other?

There are related questions, but the answer seems to change from version to version, and I haven't found any that work for the Super Key and Alt+Tab animations.

6
  • 1
    The Unity Tweak Tool is still the easiest way to get this done. There are options to disable the animations you mentioned.
    – edwinksl
    Commented Jun 29, 2016 at 16:30
  • @edwinksl I found the switch for Window Animatinos, but no settings for Dashboard and Alt+Tab fade. Do you know which settings to use?
    – jtpereyda
    Commented Jun 29, 2016 at 16:34
  • Try setting the following: 1) Unity > Search > General > Background blur: OFF, 2) Window Manager > General > {Hardware acceleration > Texture quality: Fast, Animations > Window Animations: OFF}. I don't observe any fading in or out when I Alt+Tab, so I can't help you with that.
    – edwinksl
    Commented Jun 29, 2016 at 16:43
  • @edwinksl Thank you! That seems to speed up animations a bit (kind of hard to tell for sure), though they're still present.
    – jtpereyda
    Commented Jun 29, 2016 at 16:52
  • 3
    The best way to avoid all these issues is to run a, say, Lubuntu VM whose DE is much more lightweight.
    – edwinksl
    Commented Jun 29, 2016 at 16:56

5 Answers 5

10

From unity tweak tool go to General and switch off Windows animations as seen below:

enter image description here

If you don't have it, you can install it with sudo apt install unity-tweak-tool.

9

For the super key animation, you can try to disable background blur, using the Unity Tweak Tool, disabling any suggestion, history, etc, can speed up the super key.

To alt-tab I don't know anything that can disable the effects, but in Unity Tweak Tool you can disable windows animation on the section Window Manager -> General, for me, this was very significant to performance.

What you can do as well is disable the shadows from windows.

1
  • 1
    Window Manager -> General-> Window Animation -> Off worked for disabling alt+tab animation.
    – anargund
    Commented Feb 23, 2017 at 0:49
6

It turned out I just needed to enable video acceleration in VirtualBox. This was more effective in speeding up my virtual Ubuntu than disabling animations.

  1. Shut down the guest OS.
  2. In VirtualBox Manager, right-click the VM.
  3. Go to Display.
  4. In the Screen tab, check "Enable 3D Acceleration."
3

EDIT: I didn't read you saying that you don't want to switch versions. I find Synapse a better replacement for the Dashboard and Ubuntu MATE's Alt+Tab displays some handy previews while switching windows. But that's REALLY up to you, in this case. I never found any improvements in disabling visual effects on Ubuntu.

Since Unity is a compiz plugin and its whole functionality depends on the desktop compositing, it's difficult to make it lighter. If someday you get tired of the sluggish performance, try Ubuntu MATE. It's sort of a younger brother of Ubuntu. They share the same theming, same icons, panels, title bar... Nothing else gets that close to providing you a lighter Ubuntu experience. And 16.04 now comes with Mutiny, a left-panel interface similar to that of Unity (with global menus). Distrowatch - Ubuntu MATE. Good luck!

2

Copy and paste the following into the Terminal and press enter.

gsettings set org.gnome.desktop.interface enable-animations false

The above command will disable the animation of the icon. If you wish to bring it back, copy & paste the following command:

gsettings set org.gnome.desktop.interface enable-animations true

That’s it! Check the “Applications” menu. You should no longer see the animation of the icons. Instead, you will see all the application icons appear at once.

1
  • 1
    As shown above. Can also use dconf-editor if you would like to use a GUI. Navigate to org>gnome>desktop>interface and un-check "enable-animations"
    – Seek Truth
    Commented May 12, 2021 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .