1

Before you storm me with links to other threads, I'm a novice Linux user and this is my foray into the Linux world. I do like to fix things myself but I've been trying various things for ages and I still can't figure this one out and it's pissing me off since I never imagined setting up an OS can be this chaotic.

My laptop runs Ubuntu 16.04, NVIDIA driver version 367.27 and whenever I switch nvidia-settings to performance mode, tearing occurs. The solution I lived with for quite some time was to simply switch to Intel which solves the tearing but the performance is horrible. Simply dragging something from Dash to desktop is horribly slow which for performance mode was a breeze but with the added tearing.

So, I'm looking for a fix to this problem. I did notice a few issues I was having while trying out the workarounds in the internet:

  1. Edits to xorg.conf keeps on resetting to default ones whenever I logout and log back in. I once tried to make it read-only but then I never got to see welcome screen.
  2. Some workarounds were related to the OpenGL Settings but I only have one option Use Conformant Texture Clamping which is checked by default. So, there are no options pertaining to VSync there.
  3. Changing the display-manager was also put forth but last time I tried doing that, I couldn't even log back in.

So, is there a fix? I don't mind going back through the same things I already did because I could've made a mistake as long as it's not something that could totally wreck the OS. If not, is there a distro out there (Ubuntu based preferrably) where these problems might not exist? Also, can using another set of drivers fix the issue?

Edit #1: I have the graphics-drivers ppa installed and that's how I get the latest nvidia drivers. Even though it didn't show any problems while installing, the Additional Drivers section of Software & Updates has Nouveau selected still. Could this be causing any issues? I never took not of it since the install seemed to have went smooth.

  • Does this help: askubuntu.com/questions/760934/… – TheWanderer Jun 29 '16 at 13:06
  • I was struggling with the same thing, apparently its a well known issue that Nvidia hasn't really openly responded to yet. If your aren't gaming at all, maybe switching back to the Nouveau driver would be your best bet. I am using Nouveau with Bumblebee for the power management and couldnt be happier. – Kevin B Burns Jun 29 '16 at 13:10
  • @Zacharee1 Been there and nope. I tried reinstalling different versions many times but none of them ever seemed to change the reality. – Sangeeth Sudheer Jun 29 '16 at 14:54
  • @KevinBBurns That's a bummer. I've seen that it's an issue but thought there was a fix somewhere. Does Bumblebee work in 16.04? This is letting me down so much. I was hoping to get a grip of Linux and I thought Ubuntu would be a nice starter. – Sangeeth Sudheer Jun 29 '16 at 15:00
  • prior to Ubuntu 19.04 on install it will give you open source nouveau graphics drivers ... as of 19.04 if you have an Nvidia card normal from scratch install will give you Nvidia driver 418 which has tons of bug fixes and is more stable out of the gates than any earlier nvidia driver ... so I strongly suggest you wipe your machine if its earlier than 19.04 and do a fresh install from scratch – Scott Stensland Jun 9 '19 at 1:14
0

I have Ubuntu 16.04 LTS and Lenovo ThinkPad E540 with Nvidia Optimus - GT740M

I managed to get it working through this article:

http://www.webupd8.org/2016/08/how-to-install-and-configure-bumblebee.html

I had to pay attention to every step, especially the IBus one, that i at first didn't notice, but doing the IBus step and rebooting solved the issue.

Now i can run programs through nVidia GPU with the help of optirun command (only).

Archived contents of the link in case of the page updating/going down.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.