7

On my Ubuntu MATE 16.04, whenever I press shutdown, restart button, I get a message that at-spi-registryd.desktop program is not responding and I either need to wait for the program to finish or I could reboot/shutdown anyway (warns me that I may lose work). Why does this happen? How can I make the shutdown/restart process smoother ie. not see that message and restart/shutdown the normal way?

This is a screen shot of that message.

  • 1
    Check this: ubuntu-mate.community/t/… – JonasCz - Reinstate Monica Jun 29 '16 at 7:48
  • Thanks your link helped. I just disabled the executable /usr/lib/at-spi2-core/at-spi2-registryd using sudo-caja and everything is working properly. I wanted to know if there is any downside of not making the aforementioned file executable. – user562577 Jun 29 '16 at 8:51
  • No, the only downside is that some "Assistive technology" apps (such as screen reader or on-screen keyboard) may not work correctly. – JonasCz - Reinstate Monica Jun 29 '16 at 9:10
6

This seems to be a regression of this bug:

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/729827

So, the workaround (provided you dont need assistive technologies) would be:

sudo mv /usr/lib/at-spi2-core/at-spi2-registryd /usr/lib/at-spi2-core/at-spi2-registryd.old

This renames the file for at-spi2-registry so that the system won't run it, but maybe you also want to reopen it on launchpad.

| improve this answer | |
0

What I did to "maybe have" fixed this problem was to use Caja as root to rename /user/lib/ and renamed the "at-spi-core directory (folder)" to ORGat-spi-core. That seemed to solve the problem so far. It may not been the proper way but it has worked so far.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.