22

I recently upgraded to Ubuntu 16.04LTS, now seems like a bad decision. Lots of bugs. It doesn't resume properly after suspend. On resume it acts almost frozen. Too much hard drive activity and very slow on resume. Even mouse pointer stutters. Any fix for this?

Update: adding h/w info

System Information

Manufacturer: Dell Inc.
Product Name: Inspiron N5030                  
Version: Not Specified
Serial Number: GSZY0N1
UUID: #################
Wake-up Type: Power Switch
SKU Number: Not Specified
Family:  

Processor Information

Socket Designation: Microprocessor
Type: Central Processor
Family: Core 2 Duo
Manufacturer: Intel
ID: ##############
Signature: Type 0, Family 6, Model 23, Stepping 10
Flags:
    FPU (Floating-point unit on-chip)
    VME (Virtual mode extension)
    DE (Debugging extension)
    PSE (Page size extension)
    TSC (Time stamp counter)
    MSR (Model specific registers)
    PAE (Physical address extension)
    MCE (Machine check exception)
    CX8 (CMPXCHG8 instruction supported)
    APIC (On-chip APIC hardware supported)
    SEP (Fast system call)
    MTRR (Memory type range registers)
    PGE (Page global enable)
    MCA (Machine check architecture)
    CMOV (Conditional move instruction supported)
    PAT (Page attribute table)
    PSE-36 (36-bit page size extension)
    CLFSH (CLFLUSH instruction supported)
    DS (Debug store)
    ACPI (ACPI supported)
    MMX (MMX technology supported)
    FXSR (FXSAVE and FXSTOR instructions supported)
    SSE (Streaming SIMD extensions)
    SSE2 (Streaming SIMD extensions 2)
    SS (Self-snoop)
    HTT (Multi-threading)
    TM (Thermal monitor supported)
    PBE (Pending break enabled)
Version: Not Specified
Voltage: 3.3 V
External Clock: 200 MHz
Max Speed: 2300 MHz
Current Speed: 2300 MHz
Status: Populated, Enabled
Upgrade: None
Serial Number: Not Specified
Asset Tag: Not Specified
Part Number: Not Specified
Core Count: 2
Core Enabled: 2
Thread Count: 2
Characteristics:
    64-bit capable
2
  • Can you run top to see what is doing it? Jun 29 '16 at 5:50
  • Please provide hardware information, computer make and model and CPU make and model. Jun 29 '16 at 14:17
17

Check this: Ubuntu becomes quite laggy after wake up

And this: Slowdown after resume from suspend (Arch Linux)

In a nutshell, try the following:

sudo apt-get install msr-tools
sudo modprobe msr
sudo rdmsr -a 0x19a

If rdmsr does not give back 0 then:

sudo wrmsr -a 0x19a 0x0
4
  • How to make this change persistent?
    – tuomastik
    May 4 '17 at 20:18
  • Well fortunately this is not an issue for a time for me so I have not tested or suited the persistent solution of the above mentioned Arch Linux link for Ubuntu but it gives some clue at least. Here is the specific post what I am talking about: bbs.archlinux.org/viewtopic.php?pid=1558948#p1558948
    – osiixy
    May 5 '17 at 7:39
  • I moved the mouse dongle to another usb and it was fixed. I had a laggy wireless mouse and functioning touchpad. the fix above it didn't work for me (thanks anyway)
    – ozma
    Mar 12 '18 at 7:44
  • Unfortunately, Ubuntu becomes so sluggish that restarting is probably the faster solution. Nov 22 '20 at 13:43
0

drivers

Checking Processor mircocode firmware for Intel CPUs helps me with lagging.

I dont know why, but with this it faster hibernate, and faster unhibernate, and less laggy as I see.

Maybe its illusiion of mind.

p.s. 0x19a always on 0

p.p.s I still have lags after regular suspend

CPU After suspend

But i dont have lags after hibernation (pm-hibernate)(without restart afrer suspend)

CPU After hibernate

I dont have idea what happening, but hibernation with this drivers not lagging, and i will use only hibernation :3

0

Generally, not all required data is restored upon waking from hibernation. Especially files that are stored on the hard disk, but are needed by a running process, must be loaded into memory after the initial wake-up phase.

To find out which processes are using the hard drive, leave a session of iotop running before the hibernation. When waking up, you can see which processes are having a lot of disk interaction.

In my case it was that the automatic upgrades were always running after the wake-up, and competing with interactive applications for resources. Changing the io-niceness of automatic upgrades to idle made my user interface to be much quicker back to fully responsive after hibernation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.