0

Some time ago I triggered upgrade from Kubuntu 15.10 to 16.04 and it failed (I forgot why and with what message). When I issued sudo do-release-upgrade it failed with message:

E: The value 'wily' is invalid for APT::Default-Release as such a release is not available in the sources

Full log-output (with errors): -> paste.ubuntu.com

Then I tried sudo apt-get autoclean but it failed with similar message. So I decided to revert /etc/apt/sources.list with command sudo cp /etc/apt/sources.list.distUpgrade /etc/apt/sources.list, then I did sudo apt-get update and repeated release upgrade. Unfortunately it failed with the same result...

How should I fix this?

0

There is a much simpler way to achieve the upgrade:

1st goto -> Software Sources -> Updates

There is a field that allows the system to check for new versions: LTS only / any / never. Select "any" LTS will only be available with 16.04.1 Just remember to set it back to LTs before Oct.2016 if it's not in your nature to go in sync with every new release of (K)Ubuntu.

Then open the update-manager from the menu. After you have checked for updates, it will inform you about the availibility of a system-upgrade.

It's always recommended to read the Release-Notes beforehand for "Known issues". You find them in 7. Further information. It may also be a good idea to look at the Ubuntu-RN as this gives the underlying system, like drivers.

In case you are not certain if your sources.list is messed up right now:

You can easily reset the sources-list to it's origin without touching it with editor, as this was identified mainly to be a cause of errors.

kdesudo software-properties-kde

This will raise a GUI-window, with a reset-button in the left-bottom corner(+ other option). What does this button? It retrieves the most current list of standard-sources via Internet connection from Canonical.

As in the log-list you have offered the term vivid appears, you are requesting an impossible solution. Vivid is not on the standard servers as it is EOL (End of life cycle).

  • I used to use GUI, but it failed from time to time in the past and I had to use command line anyway. This is how I got used to CLI way of doing upgrade. Anyway this time it also failed from GUI... – Marcin Jun 28 '16 at 18:15
  • Any error-comments you can post? If it's long than use paste.ubuntu.com and quote the link in your initial question. Another option is by the way to use a DVD and add it to your package-sources. You will be represented with the question if you put it in the DVD-drive. Still wonder why the officially recommended method shouldn't work OOTB. These days you don't even have to ppa-purge/de-install external software (They are listed in etc/apt/sources.list.d/). The ppa-sources just get deactivated, that was impressive. – ellisistfroh Jun 28 '16 at 19:36
  • GUI does do-release-upgrade -m desktop -f DistUpgradeViewKDE which seems pretty similar to what I did. I have added full output of my command. – Marcin Jun 28 '16 at 20:21
  • Have you tried to switching to the main ubuntu-server in the sofware-sources programm already? By the way changing the sources-list manually is not recommended, it works with Debian, but it shows failures in (K)Ubuntu. – ellisistfroh Jun 28 '16 at 20:57
  • Try disabling the Partners-repository - before upgrade. Right now can't remember where I read this. Worth a try... Just enable it after the upgrade. – ellisistfroh Jun 28 '16 at 22:40
0

Error E: The value 'wily' is invalid for APT::Default-Release as such a release is not available in the sources occured during repositories reconfiguration. It was caused by content of /etc/apt/apt.conf where wily was set instead of xenial.

I changed this file's content to APT::Default-Release "xenial"; and next upgrade attempt finished successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.