Ubuntu 16.04 - there is no option for configuration of Touchpad like: "disable during typing", "palm detection".

Is there any workaround (as typing has become difficult issue)?

  • is there a mouse & touchpad on all settings ?? i.imgur.com/NxATSbJ.png – Mohamed Slama Jun 28 '16 at 6:18
  • Go to All Settings -> Mouse and Touchpad -> Device Tab -> Choose (Elantech) Touchpad from the scroll-down list -> Go to Touchpad Tab -> Check `Disable touchpad while typing' option. – ipse lute Jun 28 '16 at 7:36
  • 2
    @ipselute I also don't see a "devices tab" on the "Mouse and Touchpad" section of Settings. The only options under the touchpad section at "Mouse and Touchpad" are: pointer speed, tap to click, 2 finger scrolling, and natural scrolling. – rik-shaw Jul 11 '16 at 15:23

Have you tried xinput ?

xinput

This will show all your device, note the ID for your touchpad.

xinput --watch-props <device number>

Above command will show the properties for your device, if you can see a propertly lik "libinput Disable While Typing Enabled" you are good to go.

xinput set-prop 13 "libinput Disable While Typing Enabled" 1

The above command will fix it for you.

Regards, Shivam

  • Thanks Shivam, I did find out number of my device and list of property also but there was no line like" libinput Disable While Typing Enabled". I could locate palm detection property set to 0 but could not made any change in it – Kamlesh Jul 2 '16 at 8:16
  • Hi Kamlesh! Are you able to check the version of xinput using xinput -v. Mine is ( xinput version 1.6.2 XI version on server: 2.3). What all properties can you see? – user2849789 Jul 2 '16 at 9:12
  • Just another follow up, have you got libinput installed? This can be used in ubuntu 15.10+. Please refer [link](these:askubuntu.com/questions/649103/…) – user2849789 Jul 2 '16 at 9:54
  • 1
    The thing is a bit of a bummer nowadays with libinput there. We probably need to wait till the whole functionality gets ported to the new architecture. – Konrad Gajewski Aug 18 at 20:03

Installing touch pad indicator form this link http://www.ubuntuupdates.org/package/atareao_atareao/xenial/main/base/touchpad-indicator had given me some configuration help. I am able to disable touch pad while typing, but it crash frequently.

  • it is working well with Ubuntu 16.04.1 – Kamlesh Jul 29 '16 at 13:40
  • After some work around I cam across ubuntuforums.org/showthread.php?t=2316240, I came to know actually I was running two touch pad , with this work around every thing seems to be working fine – Kamlesh Sep 1 '16 at 13:42
  • Always crash upon launch, its also removed from atareao's repository – tribbloid Sep 23 '16 at 20:14

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.