3

I threw an R9 380 into my machine the other day, and with the AMDGPU drivers everything seems quite fine . . . except I no longer have any sound. I've tried setting the audio priority, but considering that sending test sounds to the device from system settings results in no sound either I'm assuming it's not a mere prioritization issue.

Opening up pavucontrol, it lists "HDMI/DisplayPort (unplugged)", which of course surprises me considering I'm reading it on my screen so it's not like the DisplayPort connection is unplugged.

I'm running Kubuntu 16.04, and currently making do my passing the audio out a USB sound card and then into a speaker, so it's not urgent, just . . . perplexing.

6

This is a known issue the open source driver amdgpu does not support audio over HDMI/DisplayPort, yet. This feature will be available as soon as DAL (Display abstraction layer) has been merged into the mainline kernel. DAL is a new driver abstraction layer by AMD. Originally, the merger was scheduled for kernel 4.7 by AMD but there were a lot of retentions at the side of the mainline kernel developers.

Hence, at the moment of this writing (kernel 4.9 is current) you only have three choices

  1. Abstain from audio output through HDMI/DisplayPort and wait
  2. Use the proprietary AMDGPU Pro driver
  3. Use a self-compiled kernel that already includes DAL

See Bug 98809 on freedesktop.org.

2
  • 1
    any word on whether DAL has been implemented yet? – user641246 Aug 3 '17 at 15:17
  • Last I checked it was working in Kubuntu 17.10 for me (in fact IIRC it started working again on 17.04). – keithzg Nov 23 '17 at 0:29
0

Have you tried to change the output profile to "Digital Stereo (HDMI) output" in "Audio Setup" from Kmix menu?

This procedure is explained here: Sending sound only through HDMI (kubuntu)

4
  • The instructions there say: 1. Right click on the volume icon in the System Tray. 2. Opened "Audio Setup" from Kmix menu. 3. Clicked on the "Audio Hardware Setup" tab. 4. Selected the best option from the Profile drop-down list. However, my options are just: * Digital Stereo (HDMI) Output * Digital Stereo (HDMI 2) Output * Digital Stereo (HDMI 3) Output * Digital Stereo (HDMI 4) Output * Digital Stereo (HDMI 5) Output * Digital Stereo (HDMI 6) Output – keithzg Jun 30 '16 at 3:35
  • Errm, let me try editing my comment again, because I wasn't expecting (a) enter to post the comment, and (b) me be unable to edit the comment later. StackExchange is weird. Anyways, thanks for the suggestion, @fabriciofc. Unfortunately, from the profile list there, all I see are "Digital Stereo (HDMI) Output" through * "Digital Stereo (HDMI 6) Output", and then versions of 5.1 and 7.1 for each of those. None of those result in any sound when using the testing buttons. – keithzg Jun 30 '16 at 3:41
  • Do you have an another sound card? What I did to fix it was Disable the Realtek HDMI Output in the sound setting (Start -> Control Panel -> Sound), then restarted. After the reboot if you open that menu you will see your tv's model number as one of the AMD audio devices (previously called "Digital Display Audio") – FabricioFCarv Jun 30 '16 at 12:06
  • The same happens to me with the "enter" key and edit doesn't work after 5 minutes editing :-/ Just adding the source : tomshardware.com/answers/id-1892798/… I think you could disable the soundcard using some manager (askubuntu.com/questions/335506/…) – FabricioFCarv Jun 30 '16 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.