5

I am a newbie to Linux (and Ubuntu).

Installed Ubuntu Mate 16.04 PowerPC on PowerMac G5 dual 2.3GHz, with English (US) as the selected language and keyboard.

Then installed (?) Cangjie 3 with "sudo apt-get install fcitx-table-cangjie3".

The Cangjie3 icon "倉" does show up on the uppper right panel under the Fcitx icon. Selected it and tried to type on LibreOffice Write only showed the English characters, not the expected Chinese word.

Opened Facitx Configuration under Control Centre, Cangjie3 Chinese (Taiwan) was listed under Input Method. Click the keyboard icon at the lower right corner, it showed English (US) as the Default keyboard layout. Clicked the setup icon, the "Table" dialogue box showed English (US) as the Keyboard Layout and "table/cangjie" and "table/Cangjie3" were listed as "Table".

I setup "Chewing" input method and it works well however it is based on Zuyin, which I am not familiar with.

So my questions are:

  1. Is the Fcitx Cangjie3 or Cangjie supported by the PowerPc version of Ubuntu mate 16.04 Mate? and
  2. If it is, what I need to so to get it work?
  3. If it is not, what an I do to have Cangjie input method (for Traditional Chinese) installed?

Since I am a newbie, details instructions will be helpful, and appreciated.

Thank you in advance for your help!

4

I found ibus-cangjie 2.4-1. Then I installed with:

sudo apt-get update
sudo apt-get install ibus-cangjie

And now it is working perfectly.

  • Glad to hear that Cangjie works for you with IBus! – Gunnar Hjalmarsson Jun 30 '16 at 2:09
2

Install "Chinese (traditional)" using Language Support. That will install some language support, including a couple of additional packages related to fcitx input methods. With those installed it should work.

Edit:

I've now tried this myself on Ubuntu 16.04 (i386), and it proved to not be sufficient. The package fcitx-table-cangjie is installed as part of the language support for "Chinese (traditional)", but after a relogin no Cangjie item showed up in Text Entry.

Then I installed fcitx-table-cangjie3 manually, and at next login Cangjie3 was selectable. I could successfully generate Chinese characters using Cangjie3.

One important note: The "Keyboard input method system" in Language Support must be fcitx.

  • Thanks. I did try the "Add/Remove Language" in "Language Support" but Cangjie was not listed. Only Chewing was listed for Chinese Taiwan. – Wai Jun 28 '16 at 23:36
  • I searched the web and found somebody used "sudo apt-get install fcitx-table-cangjie3" for Ubuntu 15.04. So I copied this method and did get the Cangjie3 installed, but not working. May be the person installed it on Intel PC, not on PowerPC. – Wai Jun 28 '16 at 23:46
  • @Wai: Just edited my answer. Possibly you missed that setting in Language Support. – Gunnar Hjalmarsson Jun 29 '16 at 1:21
  • Thanks Gunnar again for you continuous effort to help! My "Keyboard Input Method" was surely set for "facitx" . Can you elaborate a bit on how you manually install "fcitx -table-cangjie3"? Did you mean you use the "sudo apt-get install facitx-table-cangjie3" terminal command? – Wai Jun 29 '16 at 3:37
  • @Wai. Yes, that's what I meant. Have no more theories at the moment. You may want to try ibus instead of fcitx. – Gunnar Hjalmarsson Jun 29 '16 at 4:38
0

Go to System setting click on Language Support and press the Install / Remove Languages and there will be a list of languages to choose from pick Chinese Traditional.

  • Thanks. I did that but just could not see Cangjie there. – Wai Jul 1 '16 at 4:47
0
  1. Installed Ubuntu Desktop 16.04 on Intel Core, 64bits, i3-7100, with Keyboard Chinese, English (UK) and English (US) and the selected language is English UK, Chinese China, Hong Kong and Taiwan, respectively.

    The "Keyboard input method system" in Language Support must be fcitx, not iBus.

  2. Run Application "Terminal" and type:

    sudo apt-get install facitx-table-cangjie3
    

    Type in password.

    sudo apt-get install facitx-googlepinyin
    

    Type in password.

  3. Log out and log into Ubuntu again.

  4. Click in the tool bar on the menu ConfigureFcitx. Press Add, scroll down the list and select "Cangie3 (Chinese Taiwan)". Exit the window.

Done.

  • you mean fcitx? (not facitx) – Phil Aug 5 '18 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.