I am using Ubuntu 14.04 LTS and google chrome Version 51.0.2704.106 (64-bit). I could use Netflix just yesterday night and today I am having this error M7703-1003. Reloading the page would not help.

your help is much appreciated.

2 Answers 2


I just got same error M7703-1003 with Netflix on Chrome and Ubuntu 16.04.
Problem have been solved like this:

  1. close Chrome, and then RESET chrome profile (by doing a back-up of current profile):

    cd ~/.config/google-chrome/
    mv Default Default-bkp
  2. restart Chrome: it is opening on new fresh profile.

  3. inside Chrome, add the "netflix icon":

    3.1 go to Netflix chrome plugin

    3.2 go to chrome://apps, right click on Netflix icon and select Open as Window and Create Shortcut enter image description here

    Now Netflix is back available in the Dash enter image description here

Sources: Creation the fresh Chrome profile and Creation of the Netflix icon in the Dash.

  • On Ubuntu 16.094, I don't see a Default folder Jan 4, 2018 at 10:59

Netflix error M7703-1003 after loading Linux Vera 21.1. I loaded the regular (stable) version of chrome. No Bueno. I beat crap, reset crap. failed on AMPrime also. I erased Chrome and loaded the "Unstable"ChromeD 115.0.5773.4-1 version from the Software Manager. It now works like it used to. I recall I had the Beta version of chrome on the last lfc. I'm too old for this downgrade crap. Windows 7 worked fine. Should have left it alone!

  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – kanehekili
    May 30 at 23:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .