I have ubuntu 16.04 LTS running on my Pentium E2180 , 1GB RAM computer, with a 120GB SSD. I had recently installed gnome-shell, to try it out , and I got an option asking me to choose between gdm3 and lightdm. I chose gdm3 and rebooted. The ubuntu loading screen showed up , and I noticed it was taking longer than usual(most of the time i'm at login prompt in a few seconds). I then sweitched to a tty and it said

(2/2)[***   ]A start job is running for Hold for boot processes to finish up(5min30/no limit)

I am currently on Puppy Linux for now , but I'd like to have this fixed. What can I do? Thanks in advance

2 Answers 2


I fixed it myself. This is what I did

  • From the GRUB menu , I selected recovery mode

  • At the recovery menu , I selected the 'networking' option, and then root shell.

  • I then typed

    dpkg-reconfigure lightdm
  • At the prompt I selected 'lightdm'

  • And voila! Problem solved.

  • this did not work for Ubuntu 18.04 and VM version 6
    – con
    Commented Mar 1, 2021 at 15:14

I think LightDM supports both Gnome and Unity on Ubuntu 16.04.

Open up the tty, login as root and run these commands.

apt-get update

Disable gdm service just in case

service gdm disable

Remove gdm

apt-get remove gdm

Remove other unneeded gdm dependencies

apt-get autoremove

Install lightdm

apt-get install lightdm

If it doesn't make you choose a display manager when installing, or just in case enable lightdm service.

apt-get enable lightdm

It should open up lightdm after reboot, and by default Ubuntu uses lightdm if I'm not mistaken, hope this helps.

  • It does but with lightdm you can't manually lock screen on gnome...
    – fakedrake
    Commented Oct 10, 2016 at 10:50
  • In some cases you might need to substitute gdm3 for gdm in the commands. Also apt-get enable lightdm produced E: Invalid operation enable. Instead I used systemctl enable lightdm
    – gb96
    Commented Nov 29, 2017 at 2:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .