17

This question already has an answer here:

I have recently switched from firefox to google chrome on Ubuntu 16.04. The keyring application is really starting to annoy me. It keeps prompting me for password for no apparent reason. Also google chrome randomly seems to forget passwords for some sites. I would like to completely disable the keyring feature and have it just remember my passwords without me needing to enter another password. I do not care to much about security since this is my personal system that no one else has access to. How can I make chrome remember my passwords without every prompting me with keyring.

marked as duplicate by muru, Fabby, karel, Eric Carvalho, Zanna Mar 22 '17 at 21:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This answer looks better askubuntu.com/a/191490/167115 – mchid Jun 27 '16 at 13:48
  • Check this answer. You may instruct Chrome to do not use the keyring by using the option --password-store=basic. e.g, you may run chrome by $ google-chrome --password-store=basic – Jaime May 9 '18 at 13:43
8

In my Ubuntu MATE, go to Applications > Accessories > Passwords and Keys

You can also load it from shell: seahorse.

Then delete the "default" keyring.

Then reopen Chrome/ium again. It should prompt for password. Enter your password and check "remember". It worked for me.

6

For Ubuntu 16.04 Open "Password and Keys" In the view make sure "By Keyring" option is checked Then in the left side, right click on keyring or default keyring whatever it is....and click on unlock It would ask for the password...for me this was the password i set for the first time i installed ubuntu Even if u have changed login password later, enter the password used for the first time...it should work... If it does right click on keyring again and delete it. (It would also delete any passwords it might have saved)

  • 1
    Where is that setting located? – Alexander Lomia Feb 11 '17 at 12:09
  • 1
    I used the last sentence of this answer. I deleted the Default Keyring and rebooted. Upon opening Google Chrome again, it asks to add a password to protect etc. I chose not to, then another popup warning about not being secure pops up I closed (ignored) that window. Now the problem is fixed. – xtrchessreal Feb 20 '17 at 19:47
  • BTW, Google Chrome still keeps the passwords but you will have to login to your websites again, which usually is auto filled by Google like it was before this issue arrived. – xtrchessreal Feb 20 '17 at 19:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.