9

Typing Japanese on Ubuntu used to mean ibus-mozc, but ibus-mozc has been less and less maintained since 2015:

Ubuntu 15.10 is supposed to start using Fcitx rather than ibus as their default input method (input method framework), which is another reason for me to hesitate to spend my time to improve ibus-mozc

This official documentation page claims that Fcitx has become the default:

Recommended frameworks for input methods are IBus and Fcitx. The latter is the default framework in Ubuntu for Chinese, Japanese, Korean and Vietnamese.

This claim is disputed, but even if not default, now after upgrading from 2015.10 to 2016.04 ibus-mozc has a problem that makes it unusable for me, so I would like to switch to fcitx-mozc.

QUESTION: How to switch Ubuntu 2016.04 from ibus-mozc to fcitx-mozc?
I see a fcitx-mozc 16.04 package, but I guess there is more to do than just installing the package? What is the recommended procedure?

  • There's also ibus-anthy and ibus-kkc, both of which are very good. fcitx has not replaced ibus as the default. The statement on the wiki page is incorrect. That said, fcitx is perfectly good as well. – chaskes Jun 28 '16 at 3:06
  • @chaskes: Yes, for CJKV languages it has. If you install e.g. Chinese or Japanese in Ubuntu 15.10+, the accompanying language support includes fcitx input methods. Nicolas: Isn't the documentation page you linked to sufficient (even if the example is Korean)? What else is there you'd need to know? – Gunnar Hjalmarsson Jun 28 '16 at 3:22
  • @GunnarHjalmarsson: Due to other problems I can't test right now, but I copy-pasted the Korean instructions and tried to adapt them for Japanese, see answer below, if you see any error don't hesitate to modify it, thanks! – Nicolas Raoul Jun 28 '16 at 3:29
  • @GunnarHjalmarsson No, it has not. In 16.04 ibus is still the default, which is what we were talking about. Including support for fcitx input methods does not make it the default. In 15.04 or 15.10 beta, there was bug that installed fcitx by default. I filed a bug report (just that there was no warning on the assumed switch) and was told by the developers that fcitx was not being made the default, and the final release installed ibus. – chaskes Jun 28 '16 at 3:31
  • @chaskes: I'm not saying that ibus isn't always installed - it is. But default for CJKV languages has been changed to fcitx. This is probably not the right place to go into details, but I'd be happy to explain separately. (I was deeply involved in this change as a developer.) – Gunnar Hjalmarsson Jun 28 '16 at 3:38
10
  1. Install Japanese. One of the installed packages is fcitx-mozc.
  2. Close Language Support and open it again.
  3. Select fcitx as the Keyboard input method system.
  4. Log out and log in again.
  5. Click the icon at the very right of the menu bar and select System Settings.
  6. In the Personal section, click Text Entry.
  7. Click the + button, select Mozc (Fcitx), and click Add.

More info

  • Looks good to me. – Gunnar Hjalmarsson Jun 28 '16 at 3:32
  • The log out and log in again was important! Thanks. – Darren Cook Jun 2 '17 at 14:52
  • +1. On my 16.04 with Unity though, a) I didn't have to logout-login, 2) appears as Mozc (ibus) instead of fcitx. – IsaacS Dec 8 '17 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.