3

I tried Gnome 3.18 Google Drive integration feature to access my Google Drive USE GNOME 3.18 GOOGLE DRIVE INTEGRATION FEATURE IN UNITY, XFCE AND OTHER DESKTOP ENVIRONMENTS [UBUNTU 16.04]

which works fine but I didn't like it as sometimes it hangs my system when I try to open some folders.

Can anyone tell me how to remove this drive ?

img

8

Just like you, I tried this feature in Ubuntu 16.04. I thought it was nice but didn't want to use google-drive that way... then I was mildly annoyed by the fact that not even removing my google account and changing the settings on Online Accounts worked. I couldn't find the Files switch.

So I found this workaround, I hope this helps somebody. Locate the file:

~/.config/goa-1.0/accounts.conf

and edit it. You'll see some blocks of text representing the same settings you could find on the Online Accounts menu shown by @nvelosa.

Find the flag Files enabled=true under the desired google account and change it to false.

In my case I immediately saw nautilus file explorer hiding the shortcut and finding myself annoyed no more.

  • This was my same problem and solution. This also works on 17.04. Perfect – Johnny Craig Nov 17 '17 at 23:41
3

what @ubashu means is the following, Open Settings -> Online Accounts -> Google and disable Files.

Like this

  • Please edit my answer to add this to my question. – fosslinux Jul 20 '16 at 4:10
  • @ubashu Your answer did not have enough detail. Is it such a bad thing for someone else to get a few reputation points? – Jeremy Bicha Jul 21 '16 at 1:51
  • @nvelosa no it doesn't work. – Vikrant Singh Jul 29 '16 at 17:22
  • Current GUI in Ubuntu 17.04 also features bold red "REMOVE ACCOUNT" which cleans out the config files entirely. – pauljohn32 Nov 15 '17 at 7:02
  • This probably would be the right way to do it, but in my case, the online accounts displayed no accounts. Editing the config mentioned by @orla4eigner worked. – Sergey Bahchissaraitsev Apr 25 '18 at 15:27
1

I tried this feature in Ubuntu 17.04 too but it was not so fair to use. I was annoyed by the fact that in Nautilus was constantly the icon to mount the google remote drive altough I had removed it. The solution reported worked:

rm ~/.config/goa-1.0/accounts.conf

In Ubuntu 17.04 there is not the option: Settings -> Online Accounts -> Google -> Files. From there this cannot be disabled.

If you are looking for a better free solution to mount google drive then I advice you google-drive-ocamlfuse since there is no official linux plugin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.