15

I'm running Ubuntu 16.04 and a brother DCP-375CW, a printer and scanner all in one. I downloaded the drivers and used the Driver Install Tool by brother.

This is the result: the system says the drivers are installed. The printer is actually working. But Simple Scan refuses to recognize a driver and xsane won't even recognize a scanner. I tried some instructions I found on the Internet but most of them seem to be for older Ubuntu Versions.
I'm worried that there is something different with Ubuntu 16.04.

$ dpkg -l | grep -i Brother

ii  brother-cups-wrapper-common        1.0.0-10-0ubuntu6   amd64        Common files for Brother cups wrapper packages
ii  brother-udev-rule-type1            1.0.0-1             all          Brother udev rule type 1
ii  brscan-skey                        0.2.4-1             amd64        Brother Linux scanner S-KEY tool
ii  brscan3                            0.2.13-1            amd64        Brother Scanner Driver
ii  dcp375cwcupswrapper:i386           1.1.3-1             i386         Brother CUPS Inkjet Printer Definitions
ii  dcp375cwlpr:i386                   1.1.3-1             i386         Brother lpr Inkjet Printer Definitions
ii  printer-driver-brlaser             3-3build1           amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch              1.4-1               amd64        printer driver Brother P-touch label printers

12 Answers 12

3

I only had to do this single step (mentioned earlier but that answer also included other steps). I have a Brother DCP-L2500D and I run Ubuntu 16.04.

Open this file

sudo gedit -H /lib/udev/rules.d/60-libsane.rules

Add the following line to the file, just before the line # The following rule will disable USB autosuspend for the device

# Brother scanners 
ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"`

Restart (well that's two steps :-))

  • I did this. Ubuntu 16.04. Then I could scan, but my toolbar disappeared. So I'll have to undo it. – Joseph Wolf Oct 17 '17 at 23:03
  • @JosephWolf Please see my new answer below. – WinEunuuchs2Unix Mar 21 '18 at 2:10
  • Safe to assume the grave accent (`) is not intentional after the last double quote? – Josh Aug 20 at 23:13
12

I had a similar problem with the dcp-135c and Ubuntu 16.04 (upgraded from 14.04).

The solution for me was the following:

  1. Install all drivers from brother website as normal

  2. Open this file: sudo nano /lib/udev/rules.d/40-libsane.rules Add the following line to the file, just before the line "# The following rule will disable USB autosuspend for the device"

    # Brother scanners
    ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"`
    
  3. Copy the brother driver files from /usr/lib64/sane/ to /usr/lib/x86_64-linux-gnu/sane

    sudo cp /usr/lib64/sane/libsane-brother* /usr/lib/x86_64-linux-gnu/sane
    

Others had to copy the files in step 3 to /usr/lib/sane instead, maybe it depends on whether you upgraded to ubuntu 16.04 or made a fresh install.

I found this solution in this thread on Ubuntu forums.

  • 2
    Copying all files from lib64 to lib is awful advice. – Mike Shultz Jun 5 '17 at 23:30
  • I will try to update the answer with the specific files that get misplaced by the driver install script the next time i need to setup the driver again. Can you explain what the dangers are of copying /usr/lib64/ to /usr/lib? Then i can add a appropriate warning to the answer – samy Jun 6 '17 at 8:07
  • 1
    I didn't do 3rd point & 4th. It was sufficient to sudo cp /usr/lib64/sane/libsane-brother* /usr/lib/x86_64-linux-gnu/sane – kujaw Jul 7 at 13:58
  • thanks for the info @kujaw i adjusted the answer based on your and Mike Shultz feedback. – samy Jul 12 at 12:31
8

I was facing the same issue with my MFC-7840W, but I finally was successful.

Here are my notes:

  1. Install brscan3, or another variant of brscan according to your model:

    sudo dpkg -i brscan3-0.2.11-5.amd64.deb
    
  2. Install brscan-skey

    sudo dpkg -i brscan-skey-0.2.4-1.amd64.deb
    
  3. Run brscan-skey

    $ brscan-skey 
    $ brscan-skey -l
    MFC-7840W         : brother3:net1;dev0  : 192.168.1.10         Active
    
  4. Set up scanner

    sudo brsaneconfig3 -a name=MFC-7840W model=MFC-7840W ip=192.168.1.10
    
  5. Confirm it worked, look for this output:

    $ brsaneconfig3 -q
    Devices on network
      0 MFC-7840W           "MFC-7840W"         I:192.168.1.10
    
  6. Make missing symbolic links if necessary

    sudo mkdir /usr/lib/sane
    sudo ln -s /usr/lib64/sane/libsane-brother3.so /usr/lib/sane/libsane-brother3.so
    sudo ln -s /usr/lib64/sane/libsane-brother3.so.1 /usr/lib/sane/libsane-brother3.so.1
    sudo ln -s /usr/lib64/sane/libsane-brother3.so.1.0.7 /usr/lib/sane/libsane-brother3.so.1.0.7
    sudo ln -s /usr/lib64/libbrscandec3.so /usr/lib/libbrscandec3.so
    sudo ln -s /usr/lib64/libbrscandec3.so.1 /usr/lib/libbrscandec3.so.1
    sudo ln -s /usr/lib64/libbrscandec3.so.1.0.0 /usr/lib/libbrscandec3.so.1.0.0
    
  7. Confirm scanimage -L works

    $ scanimage -L
    device `brother3:net1;dev0' is a Brother MFC-7840W MFC-7840W
    
  8. Install gscan2pdf

  9. Use gscan2pdf to test scanner
  • where did those .deb packages come from? – Zanna May 8 '18 at 9:21
  • 1
    @Zanna, from the brother website under linux drivers – Nick May 16 '18 at 17:19
1

FWIW I just lost a few hours of my life getting a Brother MFC-J470DW scanner going (on Ubuntu 16.04). Finally I noted a new driver post from Brother dated 3-01-2017!! I installed that and configured the IP address and I'm good to go.

The driver that worked on support.brother.com

1

Running Brother DCP7030 on Linux Mint 17

run simple-scan as root:

sudo simple-scan

If it works, then it's a privilege issue. To solve, download udev rule (scanner setting file) from Brother website.

Then:

sudo dpkg -i brother-udev-rule-type1-1.0.0-1.all.deb

and reboot your computer

1

Someone linked to a deb udev file on the Brother website but the buttons for downloading are broken so here is there direct link:

http://www.brother.com/pub/bsc/linux/dlf/brother-udev-rule-type1-1.0.0-1.all.deb"

0

Open a Terminal window and type: sudo apt-get install sane. SANE = Scanner Access Now Easy. It'a an universal program who access scanner directly at hardware level, it doesn't require any driver. Yes, i know sane should automatically install as dependency of xsane, but I've seen situations when it's missing for some reason. xsane is just a graphical interface for sane.
Alternatively, you could install gscan2pdf : sudo apt-get install gscan2pdf.

  • I think it's not a problem with sane itself, it's probably a problem with the udev-rule-settings or the printer-network-name... my scanner only started working after giving it a reserved private IP instead of a network alias... – Neni Jun 26 '16 at 14:20
0

Brother updated software December 25, 2017.

As such most if not all the answer posted prior to March 20, 2018 are out of date.

As per this answer: How to get a Brother DCP-350C scanner working? there have been updates for:

$ dpkg -l | grep -i brother
ii  brother-udev-rule-type1                    1.0.2                                        all          Brother udev rule type 1
ii  brscan-skey                                0.2.4-1                                      amd64        Brother Linux scanner S-KEY tool
ii  brscan4                                    0.4.4-3                                      amd64        Brother Scanner Driver
ii  printer-driver-brlaser                     3-5~ubuntu1                                  amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch                      1.4-1                                        amd64        printer driver Brother P-touch label printers

Plus additional drivers for your specific printer model.

Of particular interest is the udev rule discussed in many answers has been updated and works fine.

Also brscan4 and not brscan2 or brscan3 is the preferred driver for most scanners.

Brother seemed to have dropped the ball with Linux Support prior to the December 25, 2017 update but everything seems to work flawlessly now as per the linked answer above.

Note that there are still some old Brother Websites which can be a bit misleading. If you ignore them and simply follow the instructions in the link everything will work out fine.

If not please post a comment on the link answer.

0

I had problem with Brother DCP-135C scanner on Ubuntu 16.04 64 bit that it was not detected after installing the drivers mentioned on the brother site.

The following instructions solved the problem

sudo cp /usr/lib64/* /usr/lib
sudo mkdir /usr/lib/x86_64-linux-gnu/sane
sudo cp /usr/lib64/sane/* /usr/lib/x86_64-linux-gnu/sane

Before that I unsuccessfully tried:

cp 60-libsane.rules 40-libsane.rules

and added edited this file...

sudo gedit /lib/udev/rules.d/40-libsane.rules

# Brother scanners
ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="01ce", ENV{libsane_matched}="yes"

Before

# The following rule will disable USB autosuspend for the device

and same for 60-libsane.rules

sudo gedit /lib/udev/rules.d/60-libsane.rules
0

If you can ping the ip address of your printer (10.42.0.222, for example), then that is a good sign.

The old problem may be that the config file doesn't know where to find the scanner.

Try this:

sudo -H gedit /etc/sane.d/epkowa.conf

Look for something like this (around or after line 53):

Ask your network administrator for the device's IP address or check
# for yourself on the panel (if it has one).  The port-number is very
# optional and defaults to 1865.
# Note that network attached devices are not queried unless configured
# in this file.
#
# Examples:
#
#net 192.16.136.2 1865
#net scanner.mydomain.com

Under the 192.16.136.2 1865 kind of line add your scanner/printer's ip address like so:

#net 192.16.136.2 1865
net 10.42.0.212
#net scanner.mydomain.com
  • Epson epkowa drivers aren't going to be a lot of use to Brother scanner/AIO owners, though – scruss May 2 at 16:49
0

My experience with Ubuntu upgrades has not been great. In 2015 & 2016, I downloaded and wrote latest distro on CD and tried upgrade from CD. These attempts crashed and required fresh install from same CD, but this then required re-install or re-config of items like user accounts and worst of all Brother printer / scanner.

For Ubuntu 17.04 I upgraded via Terminal and this worked well – even Brother printer / scanner survived the upgrade.

sudo apt-get update
sudo apt-get upgrade

In Oct 2017 I followed same route but Brother scanner failed to work after the upgrade.

I followed old instructions on how to re-install drivers / setup for Brother printer / scanner, in my case model DCP-J315W. My notes covered the following steps:

  1. Download Brother Printer Drivers using the tool.(linux-brprinter-installer-*.*.*-*.gz)

    The tool will be downloaded into the default Downloads directory. (The directory location varies depending on your Linux distribution.) e.g. /home/(LoginName)/Downloads

    Open a terminal window and go to the directory you downloaded the file to in the last step.

    Ctrl+Alt+T (opens Terminal Window)

    cd ~/Downloads
    

    (Ubuntu is case sensitive so use the command dir or ls to check directory names)

    Enter command to extract the downloaded file:

    gunzip linux-brprinter-installer-*.*.*-*.gz
    

    or if necessary

    sudo gunzip linux-brprinter-installer-*.*.*-*.gz
    

    Run the tool (use sudo if required):

    bash linux-brprinter-installer-*.*.*-* Brother machine name 
    

    The driver installation will start. Follow the installation screen directions.

     When you see the message

    Will you specify the DeviceURI?

    • For USB Users: Choose N(No)
    • For Network Users: Choose Y(Yes) and DeviceURI number. The install process may take some time. Please wait until it is complete.

SCANNER SOLUTION:

Unfortunately, there appear to be additional issues surrounding Brother Scanners and issues may vary upon scanner models and the version of BRSCAN required to be run. Brother.com have 4 versions of this file. Each files covers different Brother scanner models.

I tried the following steps which had worked with past versions of Ubuntu:

  1. Open file: sudo nano /lib/udev/rules.d/40-libsane.rules and add the following lines just before the line "# The following rule will disable USB autosuspend for the device"

    # Brother scanners
    ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"
    

    Using Gedit with sudo no longer works in Ubuntu 17.10, but nano works okay.

    Ctrl+O writes edits to file.

  2. Copy all files from /usr/lib64 to /usr/lib

    sudo cp /usr/lib64/* /usr/lib
    

    At this stage I was in despair after wasting hours on websearching this issue. The above steps had worked in the past and should not have been necessary under the upgrade process. Then I came across a new step which worked for Ubuntu 17.10 which makes me think there is a new bug in Ubuntu:

  3. Copy all files from /usr/lib64/sane to /usr/lib/x86_64-linux-gnu/sane

    sudo cp /usr/lib64/sane/* /usr/lib/x86_64-linux-gnu/sane
    

    This new command included notation that

    others had to copy the files in step 4 to /usr/lib/sane instead, maybe it depends on whether you upgraded to Ubuntu 16.04 or made a fresh install.

    I did not need to do this for Ubuntu 17.10.

NOTES: Other notes, websites or commands relating to this issue include:

Brother support: You can follow Brother install process on their website if you wish.

In Ubuntu 16.04 the file named 40-libsane.rules may have changed to 60-libsane.rules but in 17.10 reverted to 40-libsane.rules. In 16.04, I ensured both names existed and included the Brother Scanner edit.

The following Terminal commands can be used to identify scanners on the system:

sane-find-scanner

This usually sees the scanner but if Scanimage does not see it then you still have a problem:

scanimage -L

The following command lists installed Brother devices:

dpkg -l | grep Brother

On a fresh install, you may need to re-install Sane:

sudo apt-get install sane
sudo apt-get install libsane-extras

Check permissions are correct by adding saned to the group which owns your scanner device:

sudo adduser saned scanner

Note: Under Ubuntu 17.10, you can no longer run GUI processes as super user, such as Sane, Simple-scan. I hacked around this block but it did not help getting scanner working so just more time wasted.

0

After doing EVERYTHING I saw on various forums and blogs to make the scanner work, what fixed it was installing the EXTRA sane backends! It doesn't hurt to install them, and for me it was the solution!

Background:, I have the DSP-J562DW installed on Mint 17.3 (Ubuntu 14.04) and Kubuntu 16.10 64 bit, with WiFi too.

  • 2
    Please add information how to install the EXTRA sane backends. – mook765 Mar 24 '17 at 6:37

protected by Community May 14 '18 at 21:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.