This question already has an answer here:

I was running ubuntu with windows, and once I got my GTX 1070, and installed the nvidia drivers on windows it caused Ubuntu to go black screen whenever I would load it from grub. Additionally my asus monitor has a box that says "out of range" whenever I tried to run Ubuntu with the black screen. When I ran ubuntu it would be the black screen with the box that says "out of range", but I could still hear it going to the login screen.

I erased my SSD and reinstalled windows with the nvidia drivers and now when I try to install ubuntu it loads up from my usb, and it turns black once at the install screen. I have never had this problem until I got the GTX 1070. Does anyone know how to fix this?

marked as duplicate by David Foerster, Eric Carvalho, Pilot6, Zanna, WinEunuuchs2Unix Oct 29 '16 at 0:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Hi Christ, have you solved the problem? I met the same problem as you did. – xxx222 Aug 17 '16 at 1:52
  • Hi all, I ordered a desktop with GTX 1070, and will install Ubuntu 16.04 on it. Has the nvidia-367 driver been included with the Ubuntu distribution now or do we still need this work-around? – Zhubarb Dec 9 '16 at 8:49

There is a compiled driver that already supports GTX 1070, which is 367.

I didn't know about the nomodeset command,so what I did is just use my integrated graphics to boot up into Ubuntu and install the latest driver that supports GTX 1070 (which is 367) from the graphics-driver PPA. Do not install the latest driver from the Nvidia's website because it won't install the 32 bit drivers and causes some application fails to start, such as Steam.

After you booted up into Ubuntu using your integrated graphics or using the nomodeset, install the drivers from PPA:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-367

and after that reboot your machine, now you can start using your GTX 1070/1080. You can read my full write up.

  • Hi Abirafdi, I ordered a desktop with GTX 1070, and will install Ubuntu 16.04 (or whichever is the most recent version) on it. Do you know if the nvidia-367 driver been is included with the Ubuntu distribution now or do we still need this work-around? – Zhubarb Dec 9 '16 at 8:50
  • 2
    We don't need this workaround anymore in Ubuntu 16.04.1, It succeeds at first boot, but you still need the driver for proper multi-monitor support. – Abirafdi Raditya Putra Dec 10 '16 at 0:44

I have faced this issue with the same graphic card and finally I have solved the problem :)

Don't forget to disable the "secure boot" option in BIOS.

The first of all , you need to include in your boot the nomodeset parameter. In this topic How do I set 'nomodeset' after I've already installed Ubuntu? is explained how to include the nomodeset.

After that and hopefully , you will be able to boot and start your X but you have to install the new brand drivers for NVIDIA ( the compiled ones in the repository didn't worked for me, I guess that aren't enough updated )

http://www.nvidia.es/download/driverResults.aspx/104315/en

Follow the instructions to install (remove X (init3 will do the trick) , execute the downloaded file and follow instructions). Reboot.

I also had another problem and I hope that you don't have to face it but I was able to login in my session but not icons appears.

The problem is explained in Ubuntu 14.04 - No Unity in user account, but in guest account

And the solution that worked for me was : https://askubuntu.com/a/529128/563998

I had this exact issue recently (with gtx 1070) and the solution for me was to change the Secure Boot setting in my BIOS. I have an Asus motherboard and there were two options for secure boot - Windows OS and Other OS. So what I did is to switch to 'Other'. I had previously followed guides from the other answers in this question (adding the repo and installing driver 367).

  • which driver did u use for the nvidia 1070, the nvidia-367 or the nvidia-375 – Paul Preibisch May 18 '17 at 4:20
  • I used 367. Do you have this issue as well? I would have imagine it would be fixed by now. – MZokov May 18 '17 at 9:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.