2

After using Ubuntu 16.04's Startup Disk Creator to create a live (16.04) environment on my 4GB USB drive, I'm unable to create additional partitions (tried both FAT, Ext4, primary and logical) in the remaining unused space.

The 'Disks' application throws this error when I try to create an additional partition on the drive:

Error creating partition on /dev/sdb: Command-line `parted --align optimal --script "/dev/sdb" "mkpart primary ext2 1420MiB 3488977919b"' exited with non-zero exit status 1: Warning: The driver descriptor says the physical block size is 2048 bytes, but Linux says it is 512 bytes. (udisks-error-quark, 0)

The 'cfdisk' application throws another error when trying to do the same:

Start sector 2893824 out of range.

What am I missing?

  • 1
    Check this: Unable to delete USB Drive partitions (Block size error) - using dd as described in the top answer should fix it. – JonasCz Jun 25 '16 at 14:47
  • 1
    Maybe the Startup Disk Creator is using the dd command, which does a 'raw write' of an OS to another medium like USB drive. 'Raw write' usually renders the rest of the disk unusable. You should reformat the USB drive, download an Ubuntu ISO file and use Unetbootin to create a Live Ubuntu from that ISO file. – ipse lute Jun 25 '16 at 14:48
1

I solved my issue(*) thanks to the suggestion of ipse lute. Perhaps the suggestion of JonasCz would have worked as well but since that question was about deleting partitions, I figured (at first) it was a different issue. So if you're running into the same issue I was having, you might want to take a look at Unable to delete USB Drive partitions (Block size error) first and try if that fixes the issue. If it does, you won't need to reformat and use Unetbootin to re-create the live environment.

What I did was:

  1. Reformat the drive using the 'Disks' app (choose 'Format Disk' / CTRL+F from the hamburger menu)

  2. Create a 2GB FAT32 partition and mount it (again using the 'Disks' app)

  3. Create all other partitions on the remaining space (in my case, a single 2GB LUKS encrypted EXT4 partition)

  4. Install Unetbootin and use it to re-create the Live environment on the 2GB FAT32 partition

  5. Set the FAT32 partition to 'bootable' using the 'Disks' app.

(*) - Actually, the steps above are IMHO workarounds to bugs in both 'Startup Disk Creator' (which used a faulty block size) and Unetbootin (which failed to set the partition to 'bootable').

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.