0

I'm aware this has been asked before, but nothing in those replies helped me.

I'm using Lubuntu and up to a couple of hours ago everything worked fine (i.e. wifi was up an running). A weird problem though has since emerged. My wlan interface can see all nearby networks but can't connect to any of them. I have confirmed (with other computers) that the network is working properly.

I connected the computer using a lan cable and installed wicd, without any luck. I still see all the nearby networks, but trying to connect to my private network it first says "putting interface up", "validating authentication", then quits by reporting "not connected". Trying to connect to another, unprotected network, i get up to "obtaining ip address", then it quits without connecting.

"rfkill list" says wirelass is hard blocked (earlier it was neither soft- nor hard blocked). sudo rfkill unblock all does nothing.

I've tried to connect using another OS (booting a fresh puppy from usb) and it couldn't connect either, reporting: "ifconfig siocsifflags operation not possible due to rf-kill"

Do I have a hardware problem? Because I'm inclined to believe that's the case, if I'm having issues using a live usb...

  • There is absolutely no information to suggest anything. – Pilot6 Jun 25 '16 at 12:35
  • If a working computer suddenly stops working and even a fresh install (or using a live USB) presents the problem, doesn't that imply a hardware issue? – Digital Dracula Jun 25 '16 at 12:47
  • Maybe yes, maybe it is ame issue with some software upgrade. – Pilot6 Jun 25 '16 at 12:48
  • But I'm talking about trying an entire different OS, like Puppy. I mean, I wish you're right, but I'm baffled as to what could be a non-hardware reason for it! – Digital Dracula Jun 25 '16 at 13:06
0

I solved it, hopefully this might be helpful for someone else.

It appears I had accidentally pressed Fn + F2, which in this Fujitsu Siemens turns off the wifi. And, surprise-surprise, it remembers the choice even after a shutdown. For cryin' out loud...

  • That 'accident' is called a hardware switch. And yes, it acts like a real switch. It bypasses the operating system, ties up directly to the BIOS/UEFI. – ipse lute Jun 26 '16 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.