1

I've got TP-Link Archer T4U and Ubuntu 16.04

In order to make it work, I installed community drivers from github

The installation proccess was like this:

# sudo cp -R . /usr/src/rtl8812AU_8821AU_linux-1.0
# sudo dkms add -m rtl8812AU_8821AU_linux -v 1.0
# sudo dkms build -m rtl8812AU_8821AU_linux -v 1.0
# sudo dkms install -m rtl8812AU_8821AU_linux -v 1.0

Then came some updates from Update manager, probably kernel update and the driver stopped working.

The additional drivers applet shows:

enter image description here


I tried to reinstall it, but it says that the module is already loaded.

I'm quite new to Ubuntu. Please, help. Thanks in advance

1
  • You need to properly uninstall the driver from github. And you need to disable SecureBoot.
    – Pilot6
    Jun 25 '16 at 11:43
1

Thanks to Pilot6, he gave a good advice.

So, I fixed it.

Disabled the secure boot. Then run the command

sudo dkms remove -m rtl8812AU_8821AU_linux/1.0 --all

And then

sudo dkms install -m rtl8812AU_8821AU_linux -v 1.0

After reboot, my wi-fi works again. And now I know how to deal with it after future kernel updates. Thanks

4
  • You do not need to re-install after kernel upgrades. DKMS will handle it. SecureBoot was the problem.
    – Pilot6
    Jun 25 '16 at 12:50
  • @Pilot6 Not true. Today I've got another kernel update and this happened again even with SecureBoot "disabled". But remove/install module helped. Jun 28 '16 at 6:31
  • This means that you broke something in your DKMS system. This happens. You need to clean var/lib/dkms directory and re-install modules.
    – Pilot6
    Jun 28 '16 at 9:15
  • @Pilot6 How do you disable SecureBoot? I don't have an option for it in my bios. And how do you clean /var/lib/dkms and re-install modules. Just delete the directory or is there some commands?
    – James
    Sep 3 '16 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.