2

There is this bug (Text layout font size doesn't change): in xfce4-xkb-plugin, the panel applet that displays keyboard layouts, the font size settings are not followed (if 'text' is selected instead of 'flag').

The font type/family and style can be changed, but the keyboard language name (us, fr, etc) is displayed much bigger than it should.

enter image description here

Can this be fixed somehow?

| improve this question | | | | |
1

I have solved this on my 64bit install by overwriting the /usr/lib/x86_64-linux-gnu/xfce4/panel-plugins/xfce4-xkb-plugin with the version from trusty, and by creating a symbolic link @libxfce4util.so.6 pointing to @libxfce4util.so.7 like this:

sudo ln -s /usr/lib/x86_64-linux-gnu/libxfce4util.so.7 /usr/lib/x86_64-linux-gnu/libxfce4util.so.6
| improve this answer | | | | |
  • Could you give more details? - I think the idea is to unpack the deb and use the xfce4-xkb-plugin file from the deb to replace the file /usr/lib/x86_64-linux-gnu/xfce4/panel-plugins/xfce4-xkb-plugin. But after doing this and the link, the keyboard switcher is absent from the list in the xfce4-panel option to add a new item. – user47206 May 9 '17 at 12:31
  • doing all the above without first removing the Keyboard Layout panel app, the fix doesn't work, the font remains unchanged. – user47206 May 9 '17 at 12:43
0

As a workaround, changing the font type (family) and style instead of font size may improve the appearance: some fonts may look better, as they are (and/or appear) smaller or thiner than others.

For example DejaVu Sans Extralight

enter image description here

shows like this:

enter image description here

| improve this answer | | | | |
0

Solved in later Xfce - tested in Mint 19.1 with xfce4-panel 4.12.2 (Xfce 4.12) - where the keyboard panel applet has a new setting called "widget size" which has nothing to do with fonts anymore.

enter image description here

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy