Since I upgraded to Ubuntu 11.10, Skype can't seem to hear me any more. It's not that it transmits poor quality sound, it's just silence. I've tried the echo123 service many times, and there's nothing.

I've checked that my microphone settings are correct: Sound Recorder works fine, and Skype running in a VM [Virtualmachine] sort of works (it can hear me, but the sound stutters - probably a VM issue).

I've checked the Skype audio settings: all options are set to "Pulse Audio", as always, and I've tried with both auto-adjusting enabled and disabled, but no joy.

I've also tried using Alsa-mixer to ensure the microphone is not muted, but all seems well. When a Skype call is connected, the microphone volume appears in the audio menu in Unity, so I presume Skype is doing the right thing, whatever that is.

Skype has always worked for me, for years (since 8.10 maybe?). Any ideas why it might be unhappy now?

  • 1
    are you using an USB headset? – Evgeni Nov 14 '11 at 11:50
  • Funny how you referred to Skype like a person :D – RolandiXor Nov 14 '11 at 17:28
  • 1
    No, standard analogue microphone attached to the mic port on the docking station for my laptop. Sound recorder works fine. – ams Nov 15 '11 at 12:40
  • I've now tried the laptop's built-in mic, and the external mic plugged into the laptop directly. All work in sound settings. None work in Skype. :( – ams Nov 15 '11 at 12:46
  • Roland - careful, don't say that too loud - you'll hurt Skype's feelings! No wait, mine won't hear you even if you shout .... :( – ams Nov 15 '11 at 12:50

Solved: I installed pavucontrol (as recommended here) and discovered that Skype was connected to the "Monitor of Internal Audio Analogue Stereo", instead of the "Internal Audio Analogue Stereo" itself.

The input was easily switched within that tool, and Skype works once more. Now I just hope the change is permanent.

  • This works for me as well (skype 4.0, Ubuntu 12.04 AMD64), but the change is not permanent (not sure what makes the sound settings return to the old pattern). Have you found a way to make it permanent? – Filbuntu Jul 1 '12 at 9:37
  • It seems to be. I wiped my machine and installed 12.04 afresh (with new partition layout), and it still works. Same home directory though. – ams Jul 2 '12 at 13:40
  • Nice for you. I have to set both (recording&playback) to "built-in Audio Analog Stereo" instead of "Monitor of built-in Audio Digital Stereo (HDMI)". But unfortunately after a while it returns to HDMI, even though I press the lock sign in pavucontrol ... I suspected it returns to HDMI when a system alert sound is played (e.g. incoming email). Other sounds (music, ...) still working. Any tip? – Filbuntu Jul 3 '12 at 5:47

When you are in sound settings the bar is filling, like the mic is working? If yes then try to uninstall skype update ubuntu in terminal and reinstalling skype. And you should try to see if another person can hear you on skype.

  • Yes, the sound settings are right. I can see the bar jump when I make a noise, and I can record things with sound recorder. – ams Nov 15 '11 at 12:47
  • I've just tried uninstalling, updating, and reinstalling, as you suggested, but no joy. :( – ams Nov 15 '11 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.