5

Is there a way to set up a key combination that brings up the Alt+Tab interface and leaves it up after releasing the keys, allowing to navigate between open windows with arrow keys and selecting them with the enter key?

I have a media pc set up with Kodi and steam, I would like to be able to alt-tab via a remote control so, I do not need a keyboard plugged in, but the normal Alt+Tab interface requires you to keep holding down alt to keep it up. this does not work with an IR remote.

I am able to bind any key combination I want to the IR remote using a FLIRC which is a USB IR receiver that emulates an HID device.

7
  • Honestly i don't use remote before but i have a wireless mouse i only use edges to switch between application like ubuntu gnome 1) this screen shot top left corner i.imgur.com/UU3tfVM.png 2) bottom left corner i.imgur.com/l3hhs6x.png 3)bottom right corner i.imgur.com/9lTdJah.png if that what you asking for i can post an answer to add Jun 25, 2016 at 1:02
  • Maybe Super-S or Super-W (to zoom out and display all windows)? I haven't used Unity in a while, but it's worth a try. The Super key is usually the "Windows" key, I think Jun 25, 2016 at 2:14
  • @MohamedSlama i am not sure what you mean.
    – mike16889
    Jun 26, 2016 at 1:59
  • @NickWeinberg that allows me to look at the zoomed out desktop but i am unable to switch between open windows/applications.
    – mike16889
    Jun 26, 2016 at 2:01
  • i mention their's another way for switching between application if it suitable here's a video youtube.com/watch?v=XhmEUqzfxX0&feature=youtu.be Jun 26, 2016 at 2:27

1 Answer 1

1

You can install Compiz using these commands:

sudo apt-get update
sudo apt-get install compiz compiz-plugins-extra

After installing compiz open dash and type ccsm.

  1. Open compiz.
  2. In compiz window management enable shift Switcher.
  3. Assign initiate key (All Workspaces).
  4. grab any key you want.

enter image description here

15
  • i have installed compiz and compiz-plugins-extra but when i open dash and type in ccsm nothing comes up.
    – mike16889
    Jun 26, 2016 at 22:46
  • restart or logout Jun 26, 2016 at 23:01
  • or write ccsm on terminal Jun 26, 2016 at 23:02
  • have tried both, i restarted and then tried via dash and terminal
    – mike16889
    Jun 26, 2016 at 23:06
  • 1
    ok great, thanks. am doing all this from the other side of the room so its hard to read whats on screen. it works perfect.
    – mike16889
    Jun 26, 2016 at 23:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.