1

After installing 16.04 from a USB stick, Laptop doesn't start anymore. The error message says No bootable devices found. I was warned during the installation that I could not continue if I don't select/create an EFI partition. I saw that there was already one (sda1) with a size of 524 MB, so I did it there.

I tried with Boot-Repair but didn't work. The output is at pastebin.ubuntu.com

In the BIOS setup I tried with and without EFI and with/without Legacy ROMs.

Thanks in advance for the help!

1

First, a clarification: Your title says you upgraded to 16.04. Does this mean that an earlier Ubuntu had been installed and was booting correctly? If so, what version? This is important mainly to establish a baseline -- if Ubuntu was installed and booting, then we know that your computer is capable of booting it correctly, which rules out certain possible explanations, such as a badly buggy firmware.

Both Ubuntu and Windows appear to be installed in EFI mode, with no trace of a former BIOS/CSM/legacy-mode installation. There's an NVRAM entry that points to the Ubuntu boot loader (check the efibootmgr data in your Boot Repair output), but it's clearly not working. This can happen because of a defective firmware or because of corrupted data in the NVRAM. It could also be that the system is trying to boot in BIOS/CSM/legacy mode for some reason. Therefore, my first suggestion is to enter your firmware setup utility and disable any hint of BIOS-mode support. This is most likely to be referred to as "legacy boot support," an active "Compatibility Support Module (CSM)," or something else. It could be flipped, though; you might need to ensure that EFI/UEFI-mode booting is enabled, and favored over BIOS/CSM/legacy booting.

If that doesn't help, then I suggest you try the following:

  1. Enter your firmware setup utility.
  2. Locate the option to reset all options to their defaults and use it. This will probably wipe out the existing boot entries.
  3. Re-run Boot Repair.

If that doesn't help, then try entering the Advanced menu in Boot Repair and selecting the option to back up and rename boot loaders. This is an ugly hack of a workaround for buggy EFIs that ignore their boot entries, which seems to be what's happening on your system. This should not be necessary if you previously had a working Ubuntu installation on the computer, but it may be necessary if this is your first Ubuntu installation and your firmware is buggy. (A better option in this case is to return the computer to the store for a refund and get something that's not broken, but this may not be possible if you're beyond the return period.)

0

In the end I had to select the option to complete erase the hard disk and install Ubuntu. That was the only way to make it boot. I had tried every single answer I found on Internet and changed the settings in the BIOS/UEFI, but nothing helped me. Of course I followed the suggestions from @rod-smith but unfortunately without success.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.