4

I'm trying to connect to a Windows network/printer and Ubuntu keeps asking for a username and password authentication. The problem is that the Windows network doesn't have any password authentication enabled. Before upgrading to 16.04 it's was working ok, without the need of password.

7
  • Can't you select anonymous user and select remember forever? – ILOVEKODI Jun 24 '16 at 0:19
  • No. This option doesn't show up for me. (I'm on Ubuntu MATE) – Caio Ramos Jun 24 '16 at 0:34
  • Are you using the standard file manager in mate or a different one? And are you attempting to connect to a share and printer on a Windows pc? – ILOVEKODI Jun 24 '16 at 1:16
  • If you are open file manager, click on network and select pc, I still receive anonymous user prompt in 16.04 – ILOVEKODI Jun 24 '16 at 1:19
  • I'm using the default file manager on Mate (Caja). I have othes windows PC's in this network that can access shared files (and the printer) without any password authentication. – Caio Ramos Jun 24 '16 at 1:28
2

I realized I just had to use my system password (that I use to login to Ubuntu)

0

Aside from the usual, "You need to put a password on your fileshares" response I will offer the following reply. More to the point, however, more modern versions of windows are starting to enforce the need for having a password. This is a good thing.

Following may be a post that has your answer. https://serverfault.com/questions/630631/how-to-make-samba-share-to-not-ask-for-password

I was thrown off by your mention of the printer. My comments are about connecting to a fileshare.

2
  • He just upgraded Ubuntu not Windows and was working on previous version. He is not setting up a samba share, he is connecting to his Windows share – ILOVEKODI Jun 24 '16 at 1:15
  • Exactly. The problem must be my Ubuntu's present configuration. – Caio Ramos Jun 24 '16 at 1:29
0

After doing some research this issue appears to be fixed in samba version 4.3.9.

sudo apt-get update

sudo apt-get upgrade

Possibly

sudo apt-get dist-upgrade

This should resolve your issue and allow you to click anonymous and remember forever choice.

If at 4.3.9, follow the guide on this website to mount Windows shares permanently.

https://wiki.ubuntu.com/MountWindowsSharesPermanently

3
  • My samba is already on 4.3.9 and my system is fully upgraded. – Caio Ramos Jun 24 '16 at 2:20
  • Caio, I added a link at the bottom to manually add the shares permanently. This should work but takes a little setup – ILOVEKODI Jun 24 '16 at 2:28
  • Ok, I'll try it later ;) – Caio Ramos Jun 24 '16 at 2:31
0

Firstly, right click on your Windows 7 Computer icon and then select Properties. There, you shall find and right down your Computer's Name, e.g. «Alex-PC». That is the username that Ubuntu 16.04 is asking for.
Secondly, give as password your Ubuntu's 16.04 system password and voila, you are ready to go.

P.S.: Keep in mind that you must have disabled network need for password from your Windows 7 advanced network options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.