Hi so I'm a complete Ubuntu beginner and I have just installed it. So the problem is that I am connected to the Wifi (wireless) but I can't actually use the internet. I am using Ubuntu 16.04.

  • Then thats a problem with your wifi
    – Adriaan
    Jun 23, 2016 at 21:45

6 Answers 6


I found a simple fix. I didn't have any problems pinging IP addresses; I ran into problems when I tried to issue a command like:

ping google.com

In other words, I could connect to the internet, as affirmed by the wifi indicator, but I was having problems turning domain names into IP addresses. This process is handled by the text file /etc/resolv.conf, so I decided perhaps it need to be updated. I issued the command:

sudo resolvconf -u

but Ubuntu spit this back at me:

/etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symbolic link to /run/resolvconf/resolv.conf

This was the source of my problem: somehow /etc/resolv.conf was pointing to /run/resolvconf/resolv.conf . Fortunately, once I removed the bad symbolic link and created a new symbolic link the wifi worked immediately. That is, I ran the following commands:

sudo rm /etc/resolv.conf
sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf

and the wifi was back up! I hope this simple solution works for you too!

  • 1
    This worked for me on Ubuntu 16.04. Have been looking for a simple answer like this for ages!
    – Arkya
    Dec 7, 2017 at 8:53
  • After following the mentioned steps, as an additional step, I had to set DNS server IP from the network settings. Then that IP saved in the /etc/resolv.conf . Finally it worked. Apr 26, 2019 at 4:57
  • good grief. I was about to throw the machine away, assuming undiagnosable hardware failure
    – Reb.Cabin
    Dec 26, 2021 at 17:10

knowing how to address a non working internet connection may help as follows.

opening a terminal and...

See if you can ping or traceroute to google's public dns.


If you get communication with Googl's public DNS then skip down to the last step on DNS.

If you're not getting a ping/traceroute to Goole's DNS then start by making sure your wireless addapter is getting IP information with the command.


output should have ip information listed for your wireless adapter something like...

wlan0   Link encap:Ethernet  HWaddr 00:xx:xx:xx:xx:xx
    inet addr:  Bcast:  Mask:

next check to make sure you have a default route


output should have a route something like...

default         UG    0      0        0 wlan0

At this point you should be able to ping and/or traceroute to Google's public DNS "". If not then call your Internet provider for additional help with your internet connection.

Now that we can ping google's public DNS we can be well assured that our internet is working. If you're still having problems then your computer is most likely not reaching a working DNS service. You can check your DNS servers with...

cat /etc/resolv.conf 

You should also check the connection status in your network manager if you're using a desktop version of ubuntu. Once you have identified/set your DNS servers make sure you can ping them as well. If you can ping the DNS servers that you have set then the problem resides above the network layer in a firewall or application issue.


Check if systemd-resolved is running sudo systemctl status systemd-resolved

Mine wasn't, so I started it.

sudo systemctl start systemd-resolved
sudo systemctl restart network-manager

Now I have access.


This may help.

When I loaded Ubuntu 16.04.1 on my old desktop I already had Windows Vista installed. Although I used a second reformated HD disk Ubuntu keeps track of the Windows operating systems and will allow you to boot to it as an option. This seems to interfere with the WiFi it connected correctly but would not access the internet and nothing I did would fix.

I removed the original Windows disk from the system and reinstalled Ubuntu and now have no problems with my Wifi.


/etc/resolv.conf contained a local IP-configuration-definition (did not occur via LAN), which I commented out according to https://www.youtube.com/watch?v=YJpPltoXpIs


In my case, after installing KDE NEON i had the same issue. Resolved following the instructions on this post Connected to the wireless but no internet access and moosee333 instructions on resolv.conf file. My resolv.conf has this values (default ones on live usb): nameserver In my OS the resolv.conf file is located in /run/NetworkManager/ with a symlink in /etc/ I had to undo the firt part of the instructions about NetworkManager.conf, because that left the machine without wifi. I hope this comment help other users. Thank God for this great community.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .