I am using Xubuntu 16.04 from the Ubuntu Minimal Install iso (DVD). I installed Xubuntu Desktop (full) using Tasksel, appropriately and as opposed to apt-get or a GUI package manager.

16.04 is the first version in which I've encountered this type of issue. When I right click the desktop and select Desktop Settings... and then choose a directory from the dropdown menu to select a source for my wallpaper image, I am faced with a list of grayed-out options.

For example, if I navigate to usr > share > xfce4 > backdrops, every file is unavailable. ALSO: When I dragged the underlying window over to place it next to the problem window for taking my screenshot, it flashed real quick and went back to the state it was in when I opened it! See image.

The minor problem I'm facing

I am able to successfully right click an image in any file manager, outside of this options dialog, and choose Set as wallpaper, however I am curious about this and suppose I should consider submitting it as a bug.

Anyone else encountered and/ or solved this issue? I don't really need a workaround; I'm fine with the right click method (I'm not that lazy :) and further, I normally use a pure install with Openbox so I'm always looking for a reason to purge everything but my WM and xdm but... You know. Icons for productivity, all of that good stuff.


This is not a bug. The menu is for you to select a folder. Not a single file. You select the folder and when you click on Open, thumbnails of the images in that folder are created in the left window. You can then select any thumbnail you like and it automatically becomes the background image.

  • 1
    If you are right, then the title of the window, which says "Select a File", is wrong and confusing. – edwinksl Jun 23 '16 at 20:32
  • 2
    Yes, you are right. It is confusing indeed. If the developers could rename it to Select a folder for example, it would be clearer. – Stormlord Jun 23 '16 at 20:35
  • ha!! I never just tried clicking "Open." I saw the options, exited, and have done that several times now. I can't believe I missed that. Well, you are correct! Thanks. – P Smith Jun 23 '16 at 20:38
  • And here I've been using XFCE off and on for like, three years? And never experienced or realized this. Man I'm getting old. Thank you! Answer is accepted. Cheers! – P Smith Jun 23 '16 at 20:41
  • 1
    @PSmith You are correct in the name being confusing. Makes sense, but in Linux, everything is a file. tldp.org/LDP/intro-linux/html/sect_03_01.html Just thought I would share. :) – Terrance Jun 23 '16 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.