2

I'm trying to install the version above. The keyboard works fine up to the screen where I can select Install Ubuntu server. There are other options in this screen as well like Repair a broken setup. I can use the arrow keys to navigate.

Once I select Install Ubuntu server, it goes to Language selection screen. This is the part where the keyboard wouldn't respond. Even CTRL + ALT + DELETE wouldn't work.

My setup/things I've tried:

  1. AMD FM2 board. Legacy USB support is enabled

  2. Ubuntu Server 16.04 CD (I checked the MD5 for the ISO and it's correct). I also enabled 'verify disc" when burning the ISO.

  3. I've tried 2 keyboards already. I have also plugged them in on the front and back USB ports with the same results.

  4. I've successfully installed the server ISO using virtual box on my Macbook Pro and no problems encountered there.

  5. Lastly, I tried the Ubuntu 16.04 Desktop installer (burned into a DVD)and it has no keyboard problems.

Any ideas on how to fix it? Thanks a lot :)

ps. I'm downloading the 15.10 server ISO right now hoping I'll have much better luck with that.

  • 1
    Possibly related to askubuntu.com/questions/759945/… -- try disabling Secure Boot in your BIOS settings. It might also be worth trying to enable "Legacy USB support", if that's an option in your BIOS settings – Nick Weinberg Jun 23 '16 at 20:41
  • seems the suggestion below wouldn't not work if I didn't set secure boot as well. So it's goes hand in hand. Thanks! :) – mrjayviper Jun 26 '16 at 2:56
5

This may sound as a joke to you but it isn't. I was facing the same problem on an Acer laptop where both the keyboard and the touchpad were not working at the same point your keyboard doesn't. This is how I was able to overcome this problem. I'm just hoping it's going to work on your system too.

Right after you press Enter on the Install Ubuntu server option, start pressing random keys on your keyboard at a rate of approximately two per second till you see the next screen appear. This hack makes the keyboard send the keys you press and eventually it gets detected correctly and it works.

As I said, this worked in my case. It's a very "low tech" suggestion but... who knows?!

  • 1
    weird tip BUT IT WORKED. A cookie for you. thanks a lot! – mrjayviper Jun 23 '16 at 23:24
  • Yes, it certainly is weird. It seems that on some keyboard controllers this issue still exists unfortunately. I'm glad it worked. :-) – Stormlord Jun 24 '16 at 1:48
3

I was wondering why Ubuntu was being unresponsive when it got the language section. I tried doing what was suggested according to the answers that were put in this thread, unfortunately it still didn't work. I had to Disable the "Legacy USB support" then my keys became responsive. Hope this helps

0

Another Problem Is probably the UEFI settings and the BIOS keys not responding so just do what above says, press random keys to enable the keyboard doing so will send a request to the USB installer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.