2

While copying files from a Linux server to external hard drive, it shows the error message

insufficient space in hard disk

The hard disk is 2TB and the copying data size is 460GB. Why does it shows the error message anyway?

Updates:

  • I formatted the hard disk as FAT.
  • While I was using NTFS, the hard disk couldn't get mounted by server.
  • I used this command to copy cp -rp /data/dms/home/docs/run/media/root/movell/backup.
  • Now I use the normal method of copying file to hard disk. It also shows the same error.
  • 5
    Because there is not enough room on the 2Tb disk. Show us the layout of the disk (df -H) by adding it to the question. – Rinzwind Jun 23 '16 at 6:59
  • There is no data in the hard disk. Its properties shows it has 2 tb space – Shyam Sundar Jun 23 '16 at 7:02
  • 4
    I see no proof of that. – Rinzwind Jun 23 '16 at 7:03
  • 3
    What is the disk formatted as? – mchid Jun 23 '16 at 7:08
  • My guess is the drive is formatted as FAT or something weird ;) and simply allows no file sizes over 4GB. – Videonauth Jun 23 '16 at 7:09
5

Well as I guessed you formatted the Hard drive as FAT, which in fact does not allow you file sizes above 4 GB, so either you chop up the data you want to archive, or format it to something more suitable.

If you not need to access this HDD on a Windows machine you could simply go for formatting the drive as ext4 (Linux format). Gparted allows you to do this with ease.

As well what could be the cause of errors are typos. so make sure you recheck the paths you typed in.

If you need indeed to access this drive in a Windows machine you can use exFAT or ntfs. For mounting it then in Linux you need to install exfat-fuse and ntfs-3g by:

sudo apt-get install exfat* ntfs*

Then you should be able to use bigger file sizes and still mount your drive onto your server.

So to mount use the usual you would use with a FAT drive. The sdX should match your actual drive letters.

sudo mkdir -p /mnt/external
sudo mount /dev/sdX /mnt/external

If that really does not suffice then explicitly define the file-system

sudo mount -t ntfs /dev/sdX /mnt/external
  • I need this HDD access in Windows Machine. – Shyam Sundar Jun 23 '16 at 7:31
  • Now i copy the file using normal method.Then also it shows same error – Shyam Sundar Jun 23 '16 at 7:32
  • 1
    @ShyamSundar format the disk as ntfs, that should solve it. – terdon Jun 23 '16 at 7:33
  • Updated my answer for including ntfs and exFAT support. – Videonauth Jun 23 '16 at 7:34
  • when I use ntfs format the server couldn't mount the disk – Shyam Sundar Jun 23 '16 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.