0

I have a Window host 64bit 8.1 at home ( connecting to Internet via home router), I recently installed an ubuntu 32 bit guest on VM Windows player ( latest version) with NAT.

ifconfig -a on ubuntu guest shows inet addr : 192.168.2.33 . I can't ping my host machine 192.168.1.3 ( its IP is assigned via DHCP).

ipconfig on Windows host shows VMnet1 ( 192.168.254.1) and VMnet8 ( 192.168.6.1), but the Default Gateway is null.

Any advice is appreciated !

0

I believe its because its 2 different networks and you should go to your vm properties where u can put number of cpu and memory ...etc and find network and change it from nat to bridge this way ubuntu on ur vm will take ip address strait from ur router same sequence as ur host machine and its important to do that to easy share files between host and vm, even if it was another windows on vm, so u will have ur vm ip same thing like 192.168.1.xxx and xxx is any other number will be assigned automatically

  • Egytich, thanks for your answer. I have tried that. Switched to "Bridge" mode and disconnect and reconnect. Even tried ifdown and ifup on ens33 ( the virtual interface) , but still the ifconfig -a shows the old IP address. 192.168.2.33 , while my host IP is 192.168.1.3. – GoodToLearn Jun 25 '16 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.