5

This bug is really weird, cause my mouse works completely fine just before logging on to Gnome desktop. But just after I enter my password and press Enter my mouse just hangs in thin air, not recognizing any movements or clicks.

Additional Info:

1) Does the mouse even really work?

Answer: Yes, I've tried it on various different devices and it works fine. It even works on my laptop running Ubuntu 16.04 LTS with the same Gnome desktop.

Note: Although I manually installed Gnome on my laptop. But the PC back at home I installed Ubuntu Gnome edition directly from an ISO file

2) Have you tried Disconnecting and reconnecting?

Answer: Yes I have. Thing is, if I disconnect my mouse and reconnect it, it works (click&movement) for a time close to 1 second. Then it dies again :'(

3) Maybe there is a problem with your system. Checked the Hardware?

Answer: Nope I'm running on Dual-boot. And the same mouse works fine on Windows 10.

4) Is it an extremely new mouse that only works if you install special drivers?

Answer: No, I've used it on Ubuntu 14.04 before. It worked fine.

5) I wonder if you are the only one with this problem.

Answer: No, I've seen many people posting about this exact problem (many post only about their touch-pad though). But no one has bothered to explain it in detail. All strongly think Gnome3 is the culprit, but no proper solution is found yet.

Please help, I have no idea what to do!!

EDIT: I have now confirmed that it is indeed a bug related to the Gnome3.18 desktop. I just installed LXQt desktop environment and it works completely fine.

4

1 Answer 1

3

Recently, I upgraded from trusty to xenial, via do-release-upgrade and had the same problem. After the upgrade completed, after the system booted, at the gdm login screen, I was unable to click anything with my mouse. I could move it around, and sometimes scroll, but I could not click anything. I had to navigate around with various key shortcuts like alt+tab and alt+f4

I tried a ps2 mouse, a wireless usb touchpad, and a different mouse. The mouse worked fine in another machine. Dmsg did not seem to show anything useful either. I tried all the obvious, like different usb ports to no avail. I reinstalled gnome-shell and gdm, purging configurations and even trying to update to the latest gnome 3.20. Nothing worked.

After lot of frustration, I installed gnome-session-flashback. That worked after switching to lightdm. The mouse would not click anything on either gdm or gnome3, but gnome2 worked fine. So next I installed kde-plasma, which worked. Than openbox, and mate, which also worked. Next I installed cinnamon, and the mouse worked, except I could not click anything on the status/menu bar down below. Everything else worked though, very odd. But if I understand correctly, cinnamon uses both gnome2 and gnome3 code, so I thought this information could be useful to someone trying to debug.

But I really just wanted my Gnome3 back. Finally I managed to fix this bug. I tried disabling my Nvidia proprietary drivers and switched over to Nouveau. After a reboot, gnome3 worked again. If you use any proprietary drivers, try disabling those. Hope that helps.

Update: After disabling nvidia drivers, and switching to Noveau, i than reinstalled the nvidia drivers, and everything worked fine. So that's worth a shot.

4
  • Bug Report Do you mind clicking the "This affects me too" option in the website ??
    – XChikuX
    Aug 1, 2016 at 19:34
  • 1
    Sure, I just did.
    – Chev_603
    Aug 3, 2016 at 1:08
  • I have a similar problem here. Any help will be highly appreciated. Thanks
    – MYaseen208
    Aug 31, 2016 at 22:18
  • 1
    Confirming after upgrading from ubuntu 17.04 to 17.10 with nvidia drivers installed I also experienced no mouse buttons functioning. Switch to lightdm, logged in under a Unity session, switched back to Noveau drivers, and rebooted. System now works with Ubuntu on XOrg. Later switched back to nvidia drivers and functioning OK.
    – tigs001
    Oct 25, 2017 at 21:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .