1

I don't know what broke it, but my python Gobject library is missing something ... When I try to run most tools like gnome-tweak-tool which require GTK, I get an error saying :

Traceback (most recent call last): File "/usr/bin/gnome-tweak-tool", line 24, in gi.require_version("Gtk", "3.0") AttributeError: 'module' object has no attribute 'require_version'

I tried to reinstall python-gobject, for python 2 and 3, install from the source the latest version etc etc. What am I missing !!! I feel like some library is missing which is optional and it causes this ?

help !

  • 1
    what did you exactly (re) install python-gobject or python-gi? I suspect python3-gi is the one to try. – Jacob Vlijm Jun 22 '16 at 20:00
  • Hi @Xqua, did you try? – Jacob Vlijm Jun 23 '16 at 6:46
  • python3-gi is already the newest version (3.20.0-0ubuntu1). – Xqua Sep 28 '16 at 20:25
  • your gtk might be broken – Mr. Pundir Mar 28 '17 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.