5

I am attempting to run Minecraft 1.10 on Ubuntu 16.04. I've tried using multiple Java versions, specifically JDK 7, Oracle 7, Oracle 8, and Oracle 9, but only 9 managed to launch the actual game. Then, whenever I tried to join a server, I got the error:

Internal Exception: java.lang.RuntimeException: Unable to access address of buffer

Now whenever I got to the launcher in other Java versions, game output was blank and I got this error code (for Oracle 8):

Pastebin

Thanks in advance!

1
  • Please put your solution as an answer. That way, you can mark this question as solved! :) – wjandrea Jun 22 '16 at 1:19
3

For reference for anyone else having this issue, go to edit profile. In the executable box, put the path to java. (For me, it was /usr/lib/jvm/java-8-openjdk-amd64/bin/java check which version you're using) In JVM arguments, I had -Xmx2560M -Xms512M.

1
  • this worked for me – Tooniis Aug 22 '17 at 8:15
0

I had the same issues after upgrading to Ubuntu Mate 18.04. Using the above way did not work. Then I realized it was a problem with openjdk 11 so I switched to openjdk 8. Problem solved.

0

In order to fix this issue, you must install Java 8 JRE, as Minecraft does not work with Java 11.

sudo apt install openjdk-8-jre

Then in your Minecraft launch options, change your Java directory to where your Java 8 is installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.