I recently upgraded to Ubuntu 16.04 LTS and I found today that my copy/paste commands don't work in the terminal. I've tried every solution I could find with a bit of googling, but nothing seems to help.

"Right click"->"paste" will paste fine into a terminal, but "right click"->"copy" doesn't seem to copy from the terminal.

Any suggestions?

2 Answers 2


Be sure to enable Shortcuts in your gnome-terminal preferences:

enter image description here

  • 1
    Enabled. Still not working. Commented Jun 21, 2016 at 18:59
  • @AndrewWatson ok, try to reinstall it with sudo apt-get install --reinstall gnome-terminal Commented Jun 21, 2016 at 19:02
  • Just reinstalled. Still not working. Commented Jun 21, 2016 at 19:07
  • As you're a reputation 6 user: if this answers your question, don't forget to click the grey ☑ under the "0" at the left of this text to accept it, which means "yes, this answer is valid"! Commented Jul 6, 2016 at 16:46
  • Great solution, thanks Sylvain. I performed 'do-release-upgrade' from 20.04-22.04 and lost the ability to Ctrl+Shift+C and Ctrl+Shift+V ! That was really frustrating and after much searching I found this solution :)
    – Dig
    Commented Aug 24, 2023 at 15:54

I had this problem. Turned out that Ctrl+Shift was taken by gnome-tweaks to change keyboard layouts.

If this is the case with you, go to gnome-tweaks (just type it in the terminal), go to
Keyboard & Mouse > Additional Layout Options > Switching to another layout.

Ctrl+Shift will be checked. Just uncheck it and it should fix the problem.

  • 1
    Thanks! Great solution! Commented Nov 19, 2022 at 1:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .