6

I would prefer to not have directories sorted before files within the file open/save dialogs. I would like everything sorted by modification date regardless of file or directory.

I have done a fair amount of googleing with trial and error still without a solution.

specifics

  • xubuntu 14.04
  • no desktop enviornment, gui started via startx
  • thunar version 1.6.3
  • gtk2 version 2.24.23
  • gtk3 version 3.10.8
6

I have a solution for GTK applications, and a solution for dolphin. I've never figured out how to fix this for non-GTK applications (e.g., LibreOffice).

For GTK:

  1. Fire up dconf-editor.
  2. Navigate to org/gtk/settings/file-chooser.
  3. De-select the box next to sort-directories-first.
  4. Close the dialog.

For dolphin:

  1. Navigate to Control / Sort by >.
  2. De-select "Folders first" at the bottom of the menu.

Hope this helps.

EDIT: I see someone else asked / addressed this problem here. I mention it because that thread has an easy command-line answer for the GTK+ part:

gsettings set org.gtk.Settings.FileChooser sort-directories-first true
| improve this answer | |
  • thanks for the reply. I don't have an option sort-directories-first nor do I also don't have dolphin installed. – winchendonsprings Jun 25 '16 at 5:22
  • OK - you don't have dolphin because you have nautilus. They are just somewhat different system file management programs. But to address the GTK issue specifically: try the command gsettings list-keys org.gtk.Settings.FileChooser and see if there is something in there mentioning sorting or directories. The key that exists on my system is sort-directories-first. If that key is there, then try the command-line version I gave above. If not ... you can also try gsettings list-keys org.gnome.nautilus.preferences and look for an equivalent key there. – JD Baldwin Jun 27 '16 at 1:30
  • I have neither nautilus nor dolphin. I have the default xubuntu file manager, thunar. Still no results on the commands either. Thanks though – winchendonsprings Jul 1 '16 at 20:06
  • Thanks! Dolphin default sort order was driving me nuts.... I was searching under preferences/settings/whatever to get it to sort like normal ls... I rarely look at & use "toolbars" -- the option was hidden in plain sight. (Still, it's a stupid UI/usability choice, but it's still better than f'ing nautilus 16.10+, which is completely hozed.) – michael Aug 30 '17 at 23:30
1

In Thunar just set the option in the (edit>)preferences under view.

| improve this answer | |
  • This doesn't change the sort order for the file open/save dialogs of firefox or chromium though? – winchendonsprings May 29 '17 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.