3

Well, the title is pretty much it.

When I start my system I always get the same user on the login screen (this is the original user created when the system was first installed). How can I change that so I won't have to type in the actual username I use everyday each time?

| improve this question | | | | |
4

Yep that is easy :

Open the GDM custom configuration file :

gksudo gedit /etc/gdm/custom.conf

Should have a lot of comment and at the end look like this :

[daemon]

[security]

[xdmcp]

[gui]

[greeter]

[chooser]

[debug]

[servers]

You'll have to add few lines under greeter like this :

[daemon]

[security]

[xdmcp]

[gui]

[greeter]
# If true show all the users, if false show the last connected users
IncludeAll=false
# User to always show in the user list
Include=somebody,somebodyelse

[chooser]

[debug]

[servers]

Just replace "somebody,somebodyelse" by whatever you want, save the file and reboot and it should work.

More info here : http://library.gnome.org/admin/gdm/2.32/gdm.html

| improve this answer | | | | |
1

In 15.10, you can go:

  • System settings
  • User accounts
  • Unlock (top right corner)
  • Select user
  • Click automatic login

This unchecks automatic login for other users, and automatically logs into that user without a password.

If you are worried about not having a password, encrypt your disk instead (will ask for a password before login screen). If an attacker gets your hardware, the login password alone will be useless (he can just mount your partition).

| improve this answer | | | | |
0

Go to (gdmsetup): System -> Administration -> Login Screen

| improve this answer | | | | |
  • In the login as ... automatically it only has one option - the current default user. My user isn't there! – David B Oct 17 '10 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.