1

I am having weird audio issue in Intel NUC5CPYH. Right after, I install Ubuntu 16.04, I change pulse audio default.pa conf file so that it only loads hdmi as audio output. After that I reboot. Then audio won't work.

The weird thing is, I follow the following steps to get it working:
1 - Revert pulse audio default.pa conf file changes
2 - Reboot
3 - Select HDMI as default output in System Settings/Sound
4 - Do Test Sound in System Settings/Sound and hear audio work
5 - Then redo my changes for pulse audio default.pa conf file
6 - Reboot

After these steps audio works. So this tells me that the changes I make are not faulty. I know this sounds so weird but trust me that is what happened with 3 nucs already.

I know that in the end of /etc/pulse/default.pa I can just add another line that would make hdmi default output. However, I used to have a problem where although I had hdmi as default output still I couldn't hear audio. The reason I change pulse conf is actually workaround for that problem.

The changes I do in /etc/pulse/default.pa are these:

Add load-module module-alsa-sink device=hw:0,3 (hw:0,3 is HDMI in my case.).

Remove lines:

/### Automatically load driver modules depending on the hardware available  
.ifexists module-udev-detect.so  
load-module module-udev-detect  
.else  
/### Use the static hardware detection module (for systems that lack udev support)  
load-module module-detect  
.endif  

$ uname -a
Linux ubiq 4.4.0-24-generic #43-Ubuntu SMP Wed Jun 8 19:27:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

$ pulseaudio --version
pulseaudio 8.0

I have no clue why this happens at all. I hope I am doing something wrong. Any help is appreciated.

  • May be there are some configuration that should be don't on the 1st reboot after the installation. If have another installation, let it reboot once then make the changes. see if works. – user.dz Jun 20 '16 at 22:58
  • I am thinking about the same thing. However, I am not sure what it can be. If anyone could point it out to me I would try to look it up and test it. – Elshad Mustafayev Jun 21 '16 at 13:48
  • There are some generated settings stored in ~/.config/pulse/ . To verify if they are related to that issue. (1) With your modification applied to /etc/pulse/default.pa, run pkill pulseaudio; rm ~/.config/pulse/*; /usr/bin/pulseaudio --start --log-target=syslog & , test if audio works. (2) With your modification applied to /etc/pulse/default.pa , create new user, logout, login with the new user, test if audio works. – user.dz Jun 21 '16 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.