1

the following is the output of systemd-analyze blame, and systemd-analyze critical chain, is there any settings I could change/modify to speed up the boot? thank you.

after turned off and purged powerd, the boot time is 51s (lenovo t61, HDD). the updated output as following, is there any other service I could safely turn off to boot?

    systemd-analyze blame
     24.695s click-system-hooks.service
     12.831s NetworkManager-wait-online.service
     12.566s dev-sda1.device
     11.204s ModemManager.service
     10.150s apparmor.service
      7.873s NetworkManager.service
      6.783s accounts-daemon.service
      5.356s thermald.service
      3.600s gpu-manager.service
      3.153s bluetooth.service
      3.116s lightdm.service
      2.979s ofono.service
      2.870s systemd-udevd.service
      2.841s grub-common.service
      2.694s rsyslog.service
      2.292s polkitd.service
      2.174s avahi-daemon.service
      2.099s irqbalance.service
      2.032s networking.service
      1.993s plymouth-start.service
      1.993s colord.service
      1.924s systemd-tmpfiles-setup-dev.service
      1.811s systemd-user-sessions.service
     24.695s click-system-hooks.service
     12.831s NetworkManager-wait-online.service
     12.566s dev-sda1.device
     11.204s ModemManager.service
     10.150s apparmor.service
      7.873s NetworkManager.service
      6.783s accounts-daemon.service
      5.356s thermald.service
      3.600s gpu-manager.service
      3.153s bluetooth.service
      3.116s lightdm.service
      2.979s ofono.service
      2.870s systemd-udevd.service
      2.841s grub-common.service
      2.694s rsyslog.service
      2.292s polkitd.service
      2.174s avahi-daemon.service
      2.099s irqbalance.service
      2.032s networking.service
      1.993s plymouth-start.service
      1.993s colord.service
      1.924s systemd-tmpfiles-setup-dev.service
      1.811s systemd-user-sessions.service
      1.569s systemd-tmpfiles-setup.service
      1.347s lm-sensors.service
      1.336s systemd-logind.service
      1.320s systemd-modules-load.service
      1.265s upower.service
      1.220s console-setup.service
      1.215s wpa_supplicant.service
      1.204s apport.service
      1.076s user@1000.service
      1.065s systemd-journald.service
       944ms dev-hugepages.mount
       892ms systemd-rfkill.service
       887ms systemd-backlight@backlight:acpi_video0.service
       668ms systemd-update-utmp.service
       634ms udisks2.service
       589ms sys-kernel-debug.mount
       588ms dev-mqueue.mount
       540ms systemd-journal-flush.service
       538ms ufw.service
       533ms ondemand.service
       508ms dev-disk-by\x2duuid-74fe8a28\x2db355\x2d4682\x2db7ef\x2db72664b4c733.swap
       502ms systemd-hostnamed.service
       501ms dns-clean.service
       491ms speech-dispatcher.service
       485ms systemd-timesyncd.service
       469ms systemd-udev-trigger.service
       417ms systemd-sysctl.service
       405ms kmod-static-nodes.service
       351ms systemd-random-seed.service
       340ms systemd-backlight@backlight:intel_backlight.service
       320ms pppd-dns.service
       283ms snapd.socket
       246ms resolvconf.service
       178ms plymouth-read-write.service
       153ms systemd-remount-fs.service
       134ms pulseaudio.service
        76ms hddtemp.service
        65ms rc-local.service
        47ms alsa-restore.service
        13ms systemd-update-utmp-runlevel.service
        12ms ureadahead-stop.service
         7ms rtkit-daemon.service
         5ms plymouth-quit-wait.service
         3ms sys-fs-fuse-connections.mount


    systemd-analyze critical-chain
    The time after the unit is active or started is printed after the "@" character.
    The time the unit takes to start is printed after the "+" character.
graphical.target @45.233s
└─multi-user.target @45.233s
  └─click-system-hooks.service @20.536s +24.695s
    └─basic.target @18.728s
      └─sockets.target @18.727s
        └─snapd.socket @18.421s +283ms
          └─sysinit.target @18.397s
            └─apparmor.service @8.245s +10.150s
              └─local-fs.target @8.244s
                └─local-fs-pre.target @8.174s
                  └─systemd-remount-fs.service @8.020s +153ms
                    └─systemd-journald.socket @2.750s
                      └─-.slice @2.708s
  • Type typing sudo systemctl disable powerd.service and reboot to see if your boot time is any better. – Dorian Jun 20 '16 at 18:30
  • @Dorian thank you, much better now, but still took more than 48s, any other services I could turn off to improve more? – Wing Jun 20 '16 at 18:42
  • Not without starting to cause problems. Is this a laptop? And does it still suspend properly with powerd disabled? If so, then you don't need it and you can actually uninstall it with sudo apt-get remove --purge powerd. You can also disable and remove bluetooth if you don't use it in the same way. – Dorian Jun 20 '16 at 20:50
  • it is an old laptop, Lenovo T61, 2G RAM. I just did purge powerd and rebooted, it actually took a little longer, 51s. I updated systemd-analyze blame and systemd-analyze critical chain above. my mouse is bluetooth, so i have to keep it. – Wing Jun 20 '16 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.