0

On my Mac, I load an Ubuntu VM 14.04 LTS via VirtualBox. Inside that, I load the Firefox browser and the FireFTP plugin. Without changing any settings on my Mac or Ubuntu, and after having a couple years of everything working fine, suddenly my FireFTP plugin says, "Unable to make a connection. Please try again." Even though this occurs, I can SSH into hosts just fine via command line and use SFTP via FileZilla just fine. These hosts have alternative SFTP ports, and I ensured the ports were set right. I can also browse the web just fine from the Ubuntu VM.

Things tried, and their results:

  • Used browser. Can browse the web just fine from the Ubuntu VM.
  • Used SSH via command line. Can SSH into these same hosts just fine via command line.
  • Installed FileZilla and tried SFTP to these hosts. It works just fine.
  • Shut down Ubuntu, switched Virtualbox from NAT to Bridged Adapter, and tried again. Failed. So, switched back to NAT.
  • Updated my Ubuntu 14.04 all the way with the latest updates. FireFTP still fails.
  • Renamed ~/.mozilla to ~/.mozilla.LAST and launched Firefox. Reinstalled FireFTP plugin again. Tried to connect to a known good host -- still fails.
  • Grabbed a Windows laptop and tested Firefox and FireFTP from there -- works just fine on my home network.
  • Bounced router on my home network and tried everything again. Fails in Ubuntu VM FireFTP.
  • Followed these instructions and was able to successfully use Anonymous FTP to reach a host from Ubuntu VM using FireFTP. But SFTP still failed.
  • Tried to launch Firefox from command line via regular user so that I could watch debug messages. Nothing showed up out of the ordinary when attempting SFTP.

I turned on full debugging in the FireFTP plugin and it shows me this:

DEBUG: ({account:"", host:"", port:"", login:"", password:"", anonymous:false, security:"sftp", pasvmode:true, ipmode:false, treesync:false, localdir:"", remotedir:"/var/www", webhost:"", prefix:"", downloadcasemode:0, uploadcasemode:0, encoding:"UTF-8", notes:"", timezone:0, folder:"", privatekey:"", protocol:"ssh2"})
DEBUG: gConcurrent:1, gMaxCon:10, gRefreshMode:true, gTempPasvMode:true, gLoadUrl:false, fileMode:n/a, protocol:ssh2, hiddenMode:true, keepAliveMode:true, networkTimeout:30, proxyHost:, proxyPort:0, proxyType:, activePortMode:n/a, activeLow:n/a, activeHigh:n/a, reconnectMode:true, sessionsMode:true, timestampsMode:false, useCompression:true, integrityMode:true, userAgent:Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:47.0) Gecko/20100101 Firefox/47.0
Debug: this._transport.use_compression is not a function
paramikojs.SSHClient.prototype.connect@chrome://fireftp/content/js/connection/paramikojs/client.js:321:5
ssh2Mozilla.prototype.connect@chrome://fireftp/content/js/connection/ssh2.js:133:24
connect@chrome://fireftp/content/js/connection/ftpController.js:98:3
oncommand@chrome://fireftp/content/fireftp.xul:1:1

Unable to make a connection. Please try again.
Unable to make a connection. Please try again.
Debug: this._transport.use_compression is not a function
paramikojs.SSHClient.prototype.connect@chrome://fireftp/content/js/connection/paramikojs/client.js:321:5
ssh2Mozilla.prototype.connect@chrome://fireftp/content/js/connection/ssh2.js:133:24
baseProtocol.prototype.reconnect@chrome://fireftp/content/js/connection/baseProtocol.js:236:5
baseProtocol.prototype.onDisconnect/func@chrome://fireftp/content/js/connection/baseProtocol.js:191:33

Unable to make a connection. Please try again.
Unable to make a connection. Please try again.
0

The latest report from the Reviews page of the FireFTP plugin on Mozilla's website says that the latest version is broken. I rolled back to the last version from 2015 and was operational again. Here's how:

  1. Click your Addons button in FF.
  2. Click Extensions. If you have FireFTP added there, remove it and restart FF. You can leave FireFTP button if you have that installed.
  3. Click your Addons button in FF.
  4. Search for FireFTP.
  5. You'll see a little blue link that says More at the end of the FireFTP plugin description. Click it.
  6. Search for a Reviews link on the Rating. Click it.
  7. In the sidebar, click the FireFTP hyperlink above the author's name.
  8. Scroll down to the bottom and a collapsed section will say Version Information. Expand it by clicking the button on it.
  9. Click "See complete version history".
  10. Scroll down to the last known good version that you want. For me, that was November 2015 and Version 2.0.26. Click the white space to the right of the version description and a green Install button appears. Click Add to Firefox, then after downloading, click Install. Wait until you get a Restart Now dialog that pops up. Click it.
  11. Upon restart, when you click to load FireFTP (I use the FireFTP button extension to do that), it works like it used to do.
  12. Now you may want to turn off the auto-update feature for now until this FireFTP bug is fixed. To do so, click the Addons button to open it.
  13. Click Extensions.
  14. You'll see a gear icon button with a popdown menu for it. Click that.
  15. Uncheck Update Addons Automatically. Now, this isn't the recommended way to keep your browser settings, because automatic update is more secure, but will work for now until this bug is fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.