30

I've upgraded my laptop (Lenovo Z50-70) which has an i7 CPU and 8Gigs of Ram to Ubuntu 16.04 from 15.10. I've been installing updates consistently. I'm using ubuntu with Gnome desktop environment (GDM).

Lately I've been experiencing a weird problem, my CPU (including all 4 cores) are 100% used by some processes like gnome-software(Gnome software) and fwupd(Firmware update daemon). This makes my work goes down. If i even kill those processes, they are starting back again.

Is there a solution for these processes to not utilize 100% of my CPU. And I don't want answers saying use the cpulimit utility to provision the amount of CPU for those processes. I find this a core problem in Ubuntu, i'm expecting real solutions for the problem.

What I've tried so far is, Removing those PPA's i've added except the official PPA's for checking updates. That didn't work out! Attached a screenshot of htop screen of these processes.

Cpu 100% usage of gnome-software and fwupd

  • Should probably file a bug report. – mikewhatever Jun 20 '16 at 16:44
  • @mikewhatever I'm hoping i could get some hints or tips from the askubuntu community, if not I'm going to file a bug report or probably try some alternatives. – kisanme Jun 20 '16 at 16:57
  • 1
    dmesg is a command you type that will output a log. – Dorian Jun 20 '16 at 17:11
  • 2
    You should also check /var/log/apt/history.log as well as other log files in that directory such as /var/log/apt/term.log or /var/log/dpkg.log which are all places to look for clues and errors. – Dorian Jun 20 '16 at 17:44
  • 4
    There is a bug posted which may be related: bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1591868 – belacqua Aug 22 '16 at 20:49
20

Had a similar issue.

As the other answer mentioned - it is possible to determine the problem by looking at /var/log/syslog.

Within my log gnome-settings was reporting the following:

(gnome-settings-daemon:3584): dconf-CRITICAL **: unable to create file '/home/USER/.cache/dconf/user': Permission denied.

In order to fix this I ran the following command, replace USER with your username:

sudo chown USER /home/USER/.cache/dconf
5

I had exactly the same issue, same processes taking 100% of CPU. What worked for me was to upgrade software in my Ubuntu (16.04):

sudo apt-get update
sudo apt-get upgrade

After that I rebooted my pc and now the issue is gone.

4

I managed to solve it by checking syslog (/var/log/syslog). It was logging like crazy that it couldn't create the file /home/<my user>/.cache/dconf/user. When I gave this folder the correct permissions, it stopped using this much CPU.

  • 3
    «the correct permissions» It would be a good idea to include which permissions you gave and the command you issued to assign them. – Andrea Lazzarotto Aug 3 '16 at 17:13
  • 1
    That folder does not even exist on my machine. – Alexis Wilke Dec 4 '16 at 22:09
2

Permission Problem for me.

looking at:

$ cat /var/log/syslog

(gnome-software:3812): dconf-CRITICAL **: unable to create file '/home/{user}/.cache/dconf/user': Permiso denegado. dconf will not work properly.

Executing this command, the problem solved.

$ sudo chown {user} /home/{user}/.cache/dconf
2

There can be a case when there's nothing in the syslog related to the service, in which case you may want to simply restart it. To avoid looking up services and killing them manually, you can just use systemctl:

sudo systemctl restart fwupd
  • This worked for me. I didn't have the /home/[user]/.cache folder issues listed above. – meawoppl Mar 11 '18 at 1:27
1

This problem with fwupd happened to me today on one computer. I also had two instances of gnome-software running. In all, 2 CPU were clamped at 100%.

To quickly stop that mayhem, I could just kill those 3 processes:

ps -ef | less
(find processes in the list, record their PID)

kill <pid1>
kill <pid2>
kill <pid3>
...

(You may also try killall gnome-software and killall fwupd, I just find that killall command dangerous... Otherwise, in htop you can just use F9. Before confirming, make sure the correct process was selected!)

Now, @belacqua pointed us out to the following bug report on launchpad:

https://bugs.launchpad.net/ubuntu/+source/appstream-glib/+bug/1591868

I found comment 18 particularly interesting:

https://bugs.launchpad.net/ubuntu/+source/appstream-glib/+bug/1591868/comments/18

The person says that the problem is not reproducible, but if you had problems with apt-get (as in, software update / installation) then it may very well be because of that. And indeed, I had several files in the apt cache that were total crap (i.e. my Internet connection failed a couple of days ago and some of the cache files included an HTTP 302 error instead of the expected package lists.) I find this specific comment interesting because a bug is still there, but not due to the yaml file as specified there. In my case, I could not find any yaml file anywhere.

I'd bet that by fixing the apt-get cache, I fixed the problem. It looks like the code was fixed a while back already. I just need a reboot to confirm that this 100% CPU usage does not occur again.

0

Same problem with me, it also blocking my system.

After change owner of /home/{user}/.cache/dconf/user, it looks normal.

protected by Community Oct 19 '17 at 15:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.