Does anybody know how to install python-wxgtk2.8 on Ubuntu 16.04?

Is needed for ride (robot framework)

Thank you in advance!

  • 3
    python-wxgtk2.8 does not exist in the Ubuntu 16.04 repositories, but python-wxgtk3.0 does. Maybe you want to try sudo apt install python-wxgtk3.0 instead?
    – edwinksl
    Jun 20, 2016 at 11:49
  • 1
    @edwinksl RIDE doesn't work with wxpython newer than 2.8.
    – Ubuntovod
    Feb 22, 2018 at 14:34
  • @Ubuntovod Good to know, that's useful information.
    – edwinksl
    Feb 22, 2018 at 19:39

3 Answers 3


Take a turn, you are in the wrong direction!

The correct way is move on with newer release. But for side packages like this one, you can always install builds from older releases. If APT didn't raise any unmet dependencies.

A rule that may help you in future with other packages: See python-wxgtk2.8, The upstream version 2.8 is part of Debian package name. Ubuntu (dpkg/apt) allows installation of multiple copies of a package if they don't have same package name.

Tested on VBox with Ubuntu 16.04.

  1. Add needed repository and update package list

     echo "deb http://archive.ubuntu.com/ubuntu wily main universe" | sudo tee /etc/apt/sources.list.d/wily-copies.list
     sudo apt update
  2. Install it

     sudo apt install python-wxgtk2.8
  3. Remove repository entry and update package list again

     sudo rm /etc/apt/sources.list.d/wily-copies.list
     sudo apt update


Following this method on large scale can lead to unmet dependency hell. So keep in mind this is similar to PPA's. To solve issues with following packages, purge them:

  • Thank you for your message. Indeed i was searching for the proper repository to add but without success and thus the question. 1 - step done but step2 asks for the dependencies and the apt list --upgradable points to the same dependencies. Jun 21, 2016 at 9:51
  • @EftychiaThomaidou, Are they the same list I've already posted? If so go with step two it's ok, and Not apt list --upgradable and avoid apt upgrade too.
    – user.dz
    Jun 21, 2016 at 10:03
  • 1
    i've used apt-get -f install to fix the dependency issues. Jun 21, 2016 at 11:37

You can download packages from previous version at http://packages.ubuntu.com/, in this case you need http://packages.ubuntu.com/trusty/python-wxgtk2.8.

I usually choose the closest Ubuntu distro version that has the needed packages and download those. It's better to avoid it, but sometimes one can't.


This was able to resolve this problem by doing this

sudo add-apt-repository ppa:nilarimogard/webupd8

Update the package index:

 sudo apt-get update

Install python-wxgtk2.8 deb package:

sudo apt-get install python-wxgtk2.8
  • The output is add-apt-repository: command not found
    – Ubuntovod
    Feb 22, 2018 at 11:33
  • 1
    Try this apt-get install software-properties-common to install add-apt-repository tool
    – GPrathap
    Nov 2, 2018 at 8:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .