3

By default when you install the japaneese language on Ubuntu 16.04 uses the mozc method. But is inconvenient for me thefore I want to install the anthy.

So I installed these packages:

pcmagas@pcmagas-Lenovo-G70-70:~$ dpkg -l | grep anthy
ii  anthy                                                       9100h-25ubuntu1                                     amd64        input method for Japanese - backend, dictionary and utility
ii  anthy-common                                                9100h-25ubuntu1                                     all          input method for Japanese - common files and dictionary
ii  anthy-el                                                    9100h-25ubuntu1                                     all          input method for Japanese - elisp frontend
ii  libanthy0:amd64                                             9100h-25ubuntu1                                     amd64        input method for Japanese - runtime library

I also installed the support for Japaneese via the "Language support", but when I try to select the input method I cannot find the "Japaneese(Anthy)" entry but only the one that uses mozc.

Can you tell me how to enable the input method via Anthy;

5

You also need ibus-anthy or fcitx-anthy. Then you need to select either IBus or fcitx in Language Support. At next login (possibly a reboot is needed; see comment by user2281135) you should be able to find the Anthy item in Text Entry.

To install ibus-anthy you can run the following command in a terminal:

sudo apt-get install ibus-anthy
| improve this answer | |
  • As Gunnar recommended I installed ibus-anthy in Ubuntu 16.04 with sudo apt-get install ibus-anthy in terminal. In Language Support I activated IBus too and logged out and in again. The only thing what was not very clear for me is that I had to go to Text Entry and add language Japanese (Anthy) (IBus) When you have set up the language to be Japanese, there is written 日本語 (Anthy) (IBus) Overall Gunnar's response is right, just the last part was troublesome to find. – user567167 Jul 11 '16 at 18:58
  • I don't know if this applies only to Ubuntu 17.04 and beyond, but logging out and back in did not solve the problem for me. I had to completely restart the computer. Then I was able to see Anthy in the list of choices. – user2281135 May 10 '17 at 9:09
  • @user2281135: Thanks for mentioning that. I edited the answer accordingly. – Gunnar Hjalmarsson May 10 '17 at 19:52
  • Under 18.10, from a command prompt run "ibus-setup". This allows you to add a Japanese/Anthy Keyboard profile. Then set the ibus daemon to autostart on login (if it's not added automatically) – Kingsley Sep 8 '19 at 0:50
  • @Kingsley: This question is about Unity on 16.04, and there you should better not mess with ibus-setup. If you want to show how to enable input methods on Cinnamon, ask a new question about that desktop environment and answer it yourself. Please don't confuse the users with advices which don't apply to the question asked. (18.10 is EOL, btw, and hence off topic here.) – Gunnar Hjalmarsson Sep 8 '19 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.