0

This question already has an answer here:

I have Ubuntu 16.04 installed and I wanted to install Windows 10. I installed it and it skipped the GRUB and went straight to Windows 10. I used a copy of boot-repair USB disk and tried to run recommended settings but I got this message:

GPT detected. Please create a BIOS-Boot partition (>1MB, unformattedfilesystem, bios_grub flag).
This can be performed via tools such as Gparted. Then try again.

After an hour of so of trying things I finally managed to boot into Ubuntu running this:

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

But now I can't boot to Windows, can't run boot-repair in recommended settings, in advanced settings tried settings sda1 (where the UEFI partition is) but grub2 isn't detecting my Windows. Also, I have an entry for an old Windows that's incorrect.

Here's my bootinfo summary generated from boot-repair.

Here's the output of efibootmgr -v if it helps somehow:

BootCurrent: 0000Timeout: 2 seconds
BootOrder: 0000,0002,0001,2001,2002,2003
Boot0000* Windows Boot Manager HD(1,GPT,fae7a125-e7c6-4570-9978-536f1ab52ece,0x800,0x100000)/File(\EFI\ubuntu\grubx64.efi)WINDOWS.........x...B .C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...3................
Boot0001* Ubuntu PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(1,GPT,fae7a125-e7c6-4570-9978-536f1ab52ece,0x800,0x100000)/File(\EFI\ubuntu\grubx64.efi)A01 ..
Boot0002* Windows Boot Manager HD(1,GPT,fae7a125-e7c6-4570-9978-536f1ab52ece,0x800,0x100000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0003* Unknown Device: HD(1,GPT,fae7a125-e7c6-4570-9978-536f1ab52ece,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0004* Unknown Device: HD(1,GPT,fae7a125-e7c6-4570-9978-536f1ab52ece,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0005* TOSHIBA MQ01ABD100 BBS(PCMCIA,TOSHIBA MQ01ABD100 ,0x500)................-.f.......f.A.f...................................| .........A.........................
Boot0006* Unknown Device: HD(2,GPT,5fca3638-90aa-4118-8d5a-09ed4f4191fa,0x12c800,0x96000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0007* Unknown Device: HD(2,GPT,5fca3638-90aa-4118-8d5a-09ed4f4191fa,0x12c800,0x96000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0008* Unknown Device: HD(2,GPT,5fca3638-90aa-4118-8d5a-09ed4f4191fa,0x12c800,0x96000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot000A* Unknown Device: HD(2,GPT,5fca3638-90aa-4118-8d5a-09ed4f4191fa,0x12c800,0x96000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC

marked as duplicate by karel, Eric Carvalho, Thomas, Fabby, abu_bua Dec 15 '18 at 17:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

You're probably running into this bug:

https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1091464

If so, two workarounds come to mind:

  • You can disable Secure Boot, as described in more detail on this page of mine. This has the drawback that you'll lose the benefits of Secure Boot, which is designed to protect the computer against pre-boot malware.
  • You can install my rEFInd boot manager, which will then take over from GRUB as your primary boot menu. rEFInd does a better job than GRUB of launching Windows on some computers. Note that you'll probably have to add a rEFInd key to your MOK list on the first boot -- you'll probably see a blue screen that leads to a file manager in which you can select refind.cer and/or refind_local.cer from the EFI/refind/keys directory on one of your partitions. This process can be mystifying, but it's not hard if you don't panic. See this page of the rEFInd documentation for more information than you probably want about this.
  • Thanks for the answer, i uninstalled everything and tried installing Windows first and then Ubuntu. Now it boots directly to Windows, bcedit doesn't take effect anymore. Secure boot is disabled and has been disabled since the begining. I'll try rEFInd boot manager. – Conrado Garcia Berrotaran Jun 20 '16 at 23:29
  • It's starting to sound like your firmware may be defective. Some brands (Sony, older HPs, and a few others) have such problems. The best solution is to return the defective device to the store for a refund. Failing that, there are ugly and unreliable workarounds. There are tons of questions here on this subject, like this one. – Rod Smith Jun 21 '16 at 1:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.