0

Background: I recently had a spill that damaged my Dell XPS 13 Developer Edition, which was preinstalled with Ubuntu 16.04.

My motherboard has been replaced. I removed the SSD before repair; now I've put it in again and I can't boot anymore - I don't even get to grub; I just get a "No bootable device found." error and can go no further.

I hit F12 on startup and try booting from the UEFI partition. When I do this, I get an error from initramfs: "Unable to find a medium containing a live file system".

I tried setting up a USB with Boot Repair. I can boot up with this, and from there I can see that the correct partitions are still there and the Ubuntu partition still looks good on /dev/sda4.

dev/sda1 is the EFI system partition. I can mount /dev/sda4 just fine.

But how do I get the system to boot correctly again?

Thanks in advance.

  • Check if there is any BIOS option for the hard drives like AHCI or IDE and try the one or the other (maybe the new motherboard has different setting than the one you had when you installed Ubuntu and this will make the disk unbootable). – Thanos Apostolou Jun 19 '16 at 23:25
0

Try this:

Insert Ubuntu Live-Dvd/Usb.

Ensure the bios boot order is set to read the media first and start the computer

Select Ubuntu Live / Try mode.

Click on purple Ubuntu search button - enter gnome-terminal and click on its icon

In a terminal run:

exec sudo -i
mount /dev/sda4 /mnt
mkdir /mnt/boot/efi
mount /dev/sda1 /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do mount -B $i /mnt$i; done
chroot /mnt
apt-get update
apt-get install --reinstall grub-efi
grub-install /dev/sda
update-grub
exit
  • When I try to chroot, it fails. It looks like I can't run /mnt/bin/bash - I get "cannot execute binary file: Exec format error" when I try. I'm running the 64-bit Ubuntu Studio image from here: cdimage.ubuntu.com/ubuntustudio/releases/16.04/release. "file /mnt/bin/bash" shows this is an x86-64 executable. This is on an i5-5200U. Am I using the wrong Ubuntu version, or is this something else? – William Pentney Jun 20 '16 at 0:39
  • Try to run: chroot /mnt /usr/bin/bash – kyodake Jun 20 '16 at 14:42
  • I did - I still get the "Exec format error" when I try to do that as well. – William Pentney Jun 21 '16 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.