4

Everything works with Nokia BH-604. Jaybird X2 connects and after a few seconds disconnects. Both headsets work with Windows 8.1 in the same computer (dual boot). Using blueman-manager 2.0.4 I get the error in topic. How do I get Jaybird X2 to work with Ubuntu Gnome 16.04?

  • same problem here. I have a fresh xubuntu 16.04 installation on my dell latitude e6410 laptop. Trying to connect to JBL Charge3 speaker. The device was paired, but i can connect only to serial port. When Try to connect to audio sink or headset I get Connection Failed: blueman.bluez.errors.DBusFailedError: Protocol not available – Sebastian Widz Jul 22 '16 at 12:12
  • Did you solve it? – Sebastian Widz Jul 22 '16 at 12:13
  • Not yet, unfortunately. – Ohto Nordberg Jul 23 '16 at 12:52
4

This solution worked for me: https://zach-adams.com/2014/07/bluetooth-audio-sink-stream-setup-failed/

sudo apt-get install pulseaudio-module-bluetooth
pactl load-module module-bluetooth-discover

Delete the device from bluetooth devices and pair it again.

  • 4
    I get "Failure: Module initialization failed" – Ohto Nordberg Jul 27 '16 at 13:28
0

I got a new laptop, plugged in the harddisk from the non-working-bluetooth-laptop and everything worked. So this is most likely a hardware version problem, i.e. Jaybird bluetooth does not support older bluetooth hardware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.