20

I want to activate ATI/AMD proprietary FGLRX graphics driver (post-release update), but there is a problem during installation. It says:

Sorry, installation of this driver failed.

Please have a look at the log file for details: /var/log/jockey.log

How can I install this driver?

16

Remove and purge the current version, then install the updates:

  1. sudo apt-get --purge remove fglrx*
  2. sudo apt-get install fglrx-updates fglrx-amdcccle-updates
  3. Reboot

Making sure fglrx is fully removed is an important step. It didn't work for me the first time I tried to install the updates and in the end I removed each fglrx package individually, purged each one individually, removed no longer dependencies sudo apt-get autoremove, rebooted, then installed the updates sudo apt-get install fglrx-updates fglrx-amdcccle-updates, rebooted, and (as of writing) I got catalyst version 11.11 (which still doesn't work with gnome3).

12.10

  • 21 Oct 2012 - fglrx is not working in 12.10, see bug report.
  • 4 Jan 2013 - no fix yet, bug reports are on fire,
  • 27 July 2013 - Still no fix sigh

12.10 Troubleshooting

If you have problems with graphics after installing or updating to 12.10, you will need to remove fglrx and use open source drivers:

    $ sudo apt-get remove fglrx*

If you get stuck on a warning about "low graphics":

  1. Open the terminal Ctrl+Alt+F1
  2. Remove fglrx: sudo apt-get remove fglrx*
  3. Reboot: sudo reboot

For more see the SO question Can't install ATI proprietary drivers in 12.10.

13.04

  • 27 July 2013 - fglrx does not work. sigh

Notes

  • What packages are currently installed? dpkg -l fglrx*

    $ dpkg -l fglrx*
    un  fglrx          <none>         (no description available)
    un  fglrx-amdcccle <none>         (no description available)
    ii  fglrx-amdcccle 2:8.911-0ubunt Catalyst Control Center for the AMD graphics
    un  fglrx-control  <none>         (no description available)
    un  fglrx-control- <none>         (no description available)
    un  fglrx-driver   <none>         (no description available)
    un  fglrx-kernel-s <none>         (no description available)
    un  fglrx-modalias <none>         (no description available)
    ii  fglrx-updates  2:8.911-0ubunt Video driver for the AMD graphics accelerato
    
  • Confirm the drivers are working fglrxinfo

    $ fglrxinfo 
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 6300M Series
    OpenGL version string: 4.2.11733 Compatibility Profile Context
    
  • For Catalyst <=11.11 with gnome <=3.2 Expect screen flickering and system hangs.

  • AMD Catalyst Proprietary Display Driver - Linux x86 & Linux x86_64

  • Get device information: lspci or verbose lspci -vv

7

All Jockey does is install fglrx and fglrx-amdcccle in the case of normal drivers, and fglrx-updates and fglrx-amdcccle-updates when you select the post-release updates option, though it fails somehow for I don't know what reason.

You can simply install/activate ATI/AMD proprietary FGLRX graphics driver (post-release update) option by typing the following line into the terminal:

sudo apt-get install fglrx-updates fglrx-amdcccle-updates

or search for these packages within the Ubuntu Software Center and install them from there.

|improve this answer|||||
3

An excellent resource for installing the latest driver from ATI and easy to follow. Installing Catalyst latest driver from ATI in Ubuntu 11.10

Bob Bowles (ed.): I found the ATI download site very user-friendly, with good self-documentation on the download/build/deploy process. ATI Download site.

|improve this answer|||||
0

On my T400 laptop, the ATI mobility radeon graphics card has become unsupported by the latest 13.10 fglrx driver.

(II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
   compiled for 1.4.99.906, module version = 13.10.10

$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]
$ lspci -n | grep 01:00.0
01:00.0 0300: 1002:95c4

The /var/log/Xorg.0.log shows this line:

(EE) No supported AMD display adapters were found

Fixed by downgrading and locking the fglrx package with synaptic manager: http://www.howtogeek.com/117929/how-to-downgrade-packages-on-ubuntu/

As text:

  1. start synaptic
  2. search for the fglrx package
  3. choose menu Package -> force version
  4. after selecting the earlier version, click apply
  5. choose menu Package -> lock version

Now Steam on Linux works again too.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.