I saw already some similar questions here, but all look too complicated or different from my problem. I installed Linux on my laptop, and I run it along Windows, which has already been there since I bought it. The problem is that I can not use any Fn keys except to adjust sound ork instant sleeping mode. Why is that and how to bind the others (plane mode, decrease / increase brightness, turn off the screen, video controlling ones and two I still don't know what they are supposed to do)? I would like to find some tool-program or so to do it or anything...


Generally, you can add a keyboard shortcut from Settings > Keyboard, then select any tab that has the word 'Shortcut'. However, because you haven't mention your distribution, I can only offer help with Ubuntu, Ubuntu Gnome and Xubuntu, as those are the ones I have experience with. I cannot offer any explanation for the sound ork instant sleeping mode though.

1. Plane mode:

Add a shortcut for this command:

nmcli radio all off

However, this shortcut can only enable an "Airplane Mode" of some sort, not disabling it. To do that, add yet another shortcut for this command:

nmcli radio all on

Ubuntu Gnome also has an 'Airplane Mode' integrated into its Network Settings. However Network Settings does not offer binding a shortcut to its Airplane Mode.

2. Decrease / Increase brightness:

If you are using Ubuntu with Unity, the shortcut should have been enabled. If you use another desktop environment, install the power manager for that desktop. This will also pop up a notification which shows changes in the brightness in the form of a progress bar.

If you still cannot use the shortcut, then you can try using xbacklight. However, althought xbacklight works like a charm for my laptop, I've read that many people cannot use it. So try it out first in the terminal after installing to see if it works. If not, search for a command line tool that can change the brightness and proceed with the steps below. I will use xbacklight as example.

Add a shortcut for this command:

xbacklight -inc 10 -time 0

This command will increase brightness by 10% ( -inc 10) after 0 millisecond ( -time 0)

To decrease brightness by 10% after 0 millisecond:

xbacklight -dec 10 -time 0

Sadly, I still cannot get the notification of brightness right myself...

3. Turn off the screen:

If you want to turn on the screen simply by pressing a key or moving the mouse after turning off the screen, add a shortcut to this command:

xset dpms force off

If you want to turn off the screen completely (so that you can only turn it on by pressing another shortcut), add a shortcut for this command:

xrandr --output LVDS1 --off

To turn on the screen after using the previous command:

xrandr --output LVDS1 --on

If you have any problem, just sound off in the comment :)

  • I have an image of small brightness on the F5 button, thus I'd love to keep this one as a key for decreasing brightness, but it would replace 'reload' action. Is there a way how to bind it in combination with Fn button? I could have used F3 and F4, but I'd love to keep some more space on the keyboard. – Karel Šlaj Jun 19 '16 at 15:49
  • Well have you tried my suggested method, and did it work? – PyGeek03 Jun 19 '16 at 15:50
  • I have it on F3 and F4 now, but not in combination with Fn. Yep, it works. – Karel Šlaj Jun 19 '16 at 15:51
  • Well to use F5 in combination with Fn, when the pop up menu ask you to press the shortcut keys to be associated with the command, just press and hold Fn, press F5, then release both. – PyGeek03 Jun 19 '16 at 15:54
  • Accepted, I thought it is just about that vote +1, but back to the topic. It does a nothing when I hold Fn. I tryed to do it several times and once it even turned off my screen (??? what was that). And it is not pop up window, it just writed to me to choose a button I want. And if I try to push Fn + F3 or F4, it asks me whether I want to use them instead of something else. The problem is just with F5 and F6 for some reason. Do I do anything badly? – Karel Šlaj Jun 19 '16 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.